summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/duplicity-piped-password.patch
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-09-28 15:04:34 -0500
committerEric Bavier <bavier@member.fsf.org>2014-09-28 18:24:25 -0500
commit335bc6833fc75f6cbbc5f15c0d3bd9d0e1b5b170 (patch)
treed3e8f80a78cf28b825b125237004f1081ba31de5 /gnu/packages/patches/duplicity-piped-password.patch
parent182d6311c2bd3393115bac12da5154f8f33a9940 (diff)
gnu: duplicity: Fix and disable some tests.
* gnu/packages/patches/duplicity-piped-password.patch: New patch. * gnu/packages/patches/duplicity-test_selection-tmp.patch: New patch. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/backup.scm (duplicity)[source]: Add patches field. [inputs]: Add util-linux and tzdata. [arguments]: rename patch-tests phase to check-setup. Set HOME and TZDIR for tests.
Diffstat (limited to 'gnu/packages/patches/duplicity-piped-password.patch')
-rw-r--r--gnu/packages/patches/duplicity-piped-password.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/patches/duplicity-piped-password.patch b/gnu/packages/patches/duplicity-piped-password.patch
new file mode 100644
index 0000000000..db50f5df32
--- /dev/null
+++ b/gnu/packages/patches/duplicity-piped-password.patch
@@ -0,0 +1,20 @@
+This test, on three occasions, is failing with the error:
+
+ EOF: End Of File (EOF) in read_nonblocking(). Braindead platform.
+
+--- duplicity-0.6.24/testing/functional/test_final.py 2014-09-28 13:14:52.146001614 -0500
++++ duplicity-0.6.24/testing/functional/test_final.py 2014-09-28 13:13:20.333546342 -0500
+@@ -156,13 +156,6 @@
+ self.run_duplicity(options=["remove-older-than", "50000", "--force", self.backend_url])
+ self.assertEqual(self.get_backend_files(), second_chain)
+
+- def test_piped_password(self):
+- """Make sure that prompting for a password works"""
+- self.set_environ("PASSPHRASE", None)
+- self.backup("full", "testfiles/empty_dir",
+- passphrase_input=[self.sign_passphrase, self.sign_passphrase])
+- self.restore(passphrase_input=[self.sign_passphrase])
+-
+
+ class OldFilenamesFinalTest(FinalTest):
+