summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/duplicity-test_selection-tmp.patch
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-09-28 15:04:34 -0500
committerEric Bavier <bavier@member.fsf.org>2014-09-28 18:24:25 -0500
commit335bc6833fc75f6cbbc5f15c0d3bd9d0e1b5b170 (patch)
treed3e8f80a78cf28b825b125237004f1081ba31de5 /gnu/packages/patches/duplicity-test_selection-tmp.patch
parent182d6311c2bd3393115bac12da5154f8f33a9940 (diff)
gnu: duplicity: Fix and disable some tests.
* gnu/packages/patches/duplicity-piped-password.patch: New patch. * gnu/packages/patches/duplicity-test_selection-tmp.patch: New patch. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/backup.scm (duplicity)[source]: Add patches field. [inputs]: Add util-linux and tzdata. [arguments]: rename patch-tests phase to check-setup. Set HOME and TZDIR for tests.
Diffstat (limited to 'gnu/packages/patches/duplicity-test_selection-tmp.patch')
-rw-r--r--gnu/packages/patches/duplicity-test_selection-tmp.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/duplicity-test_selection-tmp.patch b/gnu/packages/patches/duplicity-test_selection-tmp.patch
new file mode 100644
index 0000000000..8f66be4dcc
--- /dev/null
+++ b/gnu/packages/patches/duplicity-test_selection-tmp.patch
@@ -0,0 +1,18 @@
+Reported upstream at https://bugs.launchpad.net/duplicity/+bug/1375019
+
+--- duplicity-0.6.24/testing/unit/test_selection.py 2014-05-09 08:27:40.000000000 -0500
++++ duplicity-0.6.24/testing/unit/test_selection.py 2014-09-28 12:28:53.932324380 -0500
+@@ -431,10 +431,10 @@
+ [(), ('1',), ('1', '1'), ('1', '2'), ('1', '3')])
+
+ self.root = Path("/")
+- self.ParseTest([("--exclude", "/home/*"),
+- ("--include", "/home"),
++ self.ParseTest([("--exclude", "/tmp/*"),
++ ("--include", "/tmp"),
+ ("--exclude", "/")],
+- [(), ("home",)])
++ [(), ("tmp",)])
+
+ if __name__ == "__main__":
+ unittest.main()