summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/emacs-elpy-dup-test-name.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-05 01:33:05 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-05 01:34:21 -0400
commitecb1b335d4a78483a13953f176b8eb3086241470 (patch)
tree077ea69e061170c62150d7efe5623d050b10efc3 /gnu/packages/patches/emacs-elpy-dup-test-name.patch
parent22d2f94eb23739280ad14aa49e18233c5d917c7e (diff)
gnu: emacs-elpy: Update to 1.35.0-2.7ff8ffa.
* gnu/packages/emacs-xyz.scm (emacs-elpy): Update to 1.35.0-2.7ff8ffa. [origin]: Apply patch. [arguments]: Disable a new test in the disable-broken-tests phase. * gnu/packages/patches/emacs-elpy-dup-test-name.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/patches/emacs-elpy-dup-test-name.patch')
-rw-r--r--gnu/packages/patches/emacs-elpy-dup-test-name.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/gnu/packages/patches/emacs-elpy-dup-test-name.patch b/gnu/packages/patches/emacs-elpy-dup-test-name.patch
new file mode 100644
index 0000000000..02f3f45cec
--- /dev/null
+++ b/gnu/packages/patches/emacs-elpy-dup-test-name.patch
@@ -0,0 +1,60 @@
+Forwarded upstream: https://github.com/jorgenschaefer/elpy/pull/2031
+
+diff --git a/test/elpy-config--insert-help-test.el b/test/elpy-config--insert-help-test.el
+index bb293ff..2584fd4 100644
+--- a/test/elpy-config--insert-help-test.el
++++ b/test/elpy-config--insert-help-test.el
+@@ -2,6 +2,6 @@
+ ;; with output. We will test its constituent functions later, and just
+ ;; make sure it doesn't throw an error here.
+
+-(ert-deftest elpy-config-should-not-fail ()
++(ert-deftest elpy-config-should-not-fail-insert-help ()
+ (elpy-testcase ()
+ (elpy-config--insert-help)))
+diff --git a/test/elpy-library-root-test.el b/test/elpy-library-root-test.el
+index fdc88b2..2f7484c 100644
+--- a/test/elpy-library-root-test.el
++++ b/test/elpy-library-root-test.el
+@@ -4,7 +4,7 @@
+ (should (f-equal? (elpy-library-root)
+ project-root))))
+
+-(ert-deftest elpy-library-root-should-find-current-directory ()
++(ert-deftest elpy-library-root-should-find-current-directory-2 ()
+ (elpy-testcase ((:project project-root
+ "p1/p2/test.py"
+ "p1/p2/__init__.py"
+diff --git a/test/elpy-open-and-indent-line-above-test.el b/test/elpy-open-and-indent-line-above-test.el
+index d846712..790dd26 100644
+--- a/test/elpy-open-and-indent-line-above-test.el
++++ b/test/elpy-open-and-indent-line-above-test.el
+@@ -1,4 +1,4 @@
+-(ert-deftest elpy-open-and-indent-line-below ()
++(ert-deftest elpy-open-and-indent-line-above ()
+ (elpy-testcase ()
+ (elpy-enable)
+ (python-mode)
+diff --git a/test/elpy-rpc-get-usages-test.el b/test/elpy-rpc-get-usages-test.el
+index 85f0ad4..be5d7c5 100644
+--- a/test/elpy-rpc-get-usages-test.el
++++ b/test/elpy-rpc-get-usages-test.el
+@@ -1,4 +1,4 @@
+-(ert-deftest elpy-rpc-get-completions ()
++(ert-deftest elpy-rpc-get-completions-usages ()
+ (elpy-testcase ()
+ (mletf* ((called-args nil)
+ (elpy-rpc (&rest args) (setq called-args args)))
+diff --git a/test/elpy-rpc-test.el b/test/elpy-rpc-test.el
+index 8b5bdca..3ff6965 100644
+--- a/test/elpy-rpc-test.el
++++ b/test/elpy-rpc-test.el
+@@ -17,7 +17,7 @@
+ (should (equal error 'elpy-rpc--default-error-callback))))
+ (elpy-rpc "test-method" nil 'success))))
+
+-(ert-deftest elpy-rpc-should-use-default-without-error-callback ()
++(ert-deftest elpy-rpc-should-use-default-without-error-callback-2 ()
+ (elpy-testcase ()
+ (mletf* ((elpy-rpc--call-blocking
+ (method params)