summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gd-fix-test-on-i686.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-07-28 14:13:26 -0400
committerMark H Weaver <mhw@netris.org>2016-07-28 14:13:26 -0400
commit622c22ccb494de789588491ad94111f7a0311ddb (patch)
tree286bb111ae2488eaef62afaf3817fcfc1c2e5cc6 /gnu/packages/patches/gd-fix-test-on-i686.patch
parent212163f8d5d51f436490d47dc37afd5052560197 (diff)
parentae46cd0e4cfb1f06d099b2cda1f9e702e86c90e9 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches/gd-fix-test-on-i686.patch')
-rw-r--r--gnu/packages/patches/gd-fix-test-on-i686.patch34
1 files changed, 0 insertions, 34 deletions
diff --git a/gnu/packages/patches/gd-fix-test-on-i686.patch b/gnu/packages/patches/gd-fix-test-on-i686.patch
deleted file mode 100644
index 6dd2e0fb03..0000000000
--- a/gnu/packages/patches/gd-fix-test-on-i686.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Disable part of the gdimagerotate test on architectures such as i686
-where intermediate floating-point operations are done with 80-bit long
-doubles, and typically later rounded to 64-bit doubles. This double
-rounding causes small differences in the resulting pixel values
-compared with other architectures, causing the image comparison to
-fail.
-
-Patch by Mark H Weaver <mhw@netris.org>.
-
---- libgd-2.2.2/tests/gdimagerotate/bug00067.c 1969-12-31 19:00:00.000000000 -0500
-+++ libgd-2.2.2/tests/gdimagerotate/bug00067.c 2016-07-18 12:19:19.885423132 -0400
-@@ -1,5 +1,6 @@
- #include <stdio.h>
- #include <stdlib.h>
-+#include <float.h>
- #include "gd.h"
-
- #include "gdtest.h"
-@@ -41,6 +42,7 @@
- return 1;
- }
-
-+#if FLT_EVAL_METHOD != 2
- sprintf(filename, "bug00067_%03d_exp.png", angle);
- path = gdTestFilePath2("gdimagerotate", filename);
- if (!gdAssertImageEqualsToFile(path, exp)) {
-@@ -48,6 +50,7 @@
- error += 1;
- }
- free(path);
-+#endif
-
- gdImageDestroy(exp);
- }