summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ghc-microlens-aeson-fix-tests.patch
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-09-20 10:49:34 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-10-08 09:13:52 +0200
commitb97f549b14402421fcfb360ddd4cff7de93b9af0 (patch)
tree855c25f617f75e29e77ff2b52b754e1249164d30 /gnu/packages/patches/ghc-microlens-aeson-fix-tests.patch
parentb74ca403cbb11c60d57b6a0148d97c6572019754 (diff)
gnu: Update Haskell ecosystem.
Bump packages’ versions to the lastest Stackage or Hackage release. Since packages are interdependent, do so in a single commit. 525 packages have been updated. These packages have been removed, because they fail to build, have no newer version available and no dependencies: corrode ghc-easytest ghc-edisonapi ghc-edisoncore ghc-pandoc-types ghc-regex-tdfa-text These have been removed, because they are no longer required: ghc-happy-1.19.9 ghc-prettyprinter-1.6 ghc-protolude-0.3 ghc-pandoc-citeproc and pandoc-citeproc have been removed, because pandoc does not use them any more. Co-authored-by: Xinglu Chen <public@yoctocell.xyz>
Diffstat (limited to 'gnu/packages/patches/ghc-microlens-aeson-fix-tests.patch')
-rw-r--r--gnu/packages/patches/ghc-microlens-aeson-fix-tests.patch27
1 files changed, 0 insertions, 27 deletions
diff --git a/gnu/packages/patches/ghc-microlens-aeson-fix-tests.patch b/gnu/packages/patches/ghc-microlens-aeson-fix-tests.patch
deleted file mode 100644
index c1ef6a837c..0000000000
--- a/gnu/packages/patches/ghc-microlens-aeson-fix-tests.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-This patch fixes the test suite to allow any order when listing the
-members of a JSON object. Aeson (being true to the JSON specification)
-does not specify an order for objects. In practice, the order depends
-on your processor architecture.
-
-See <https://github.com/bos/aeson/issues/568> for a discussion resulting
-in a similar patch fixing the Aeson tests.
-
-See <https://github.com/fosskers/microlens-aeson/issues/1> for the
-upstream bug report.
-
-diff -ruN a/test/Test.hs b/test/Test.hs
---- a/test/Test.hs 2018-12-31 15:10:50.000000000 -0500
-+++ b/test/Test.hs 2019-11-08 01:34:07.419706831 -0500
-@@ -48,8 +48,10 @@
- , testCase "" $ ("{\"a\": {}, \"b\": null}" ^? key (T.pack "b") . _Object) @?= Nothing
- , testCase "" $ ("{\"a\": 100, \"b\": 200}" ^? key (T.pack "a")) @?= Just (Number 100.0)
- , testCase "" $ ("[1,2,3]" ^? key (T.pack "a")) @?= Nothing
-- , testCase "" $ ("{\"a\": 4, \"b\": 7}" ^.. members) @?= [Number 4.0,Number 7.0]
-- , testCase "" $ ("{\"a\": 4, \"b\": 7}" & members . _Number %~ (* 10)) @?= "{\"a\":40,\"b\":70}"
-+ , testCase "" $ assertBool "" (let x = ("{\"a\": 4, \"b\": 7}" ^.. members)
-+ in x == [Number 4.0,Number 7.0] || x == [Number 7.0,Number 4.0])
-+ , testCase "" $ assertBool "" (let x = ("{\"a\": 4, \"b\": 7}" & members . _Number %~ (* 10))
-+ in x == "{\"a\":40,\"b\":70}" || x == "{\"b\":70,\"a\":40}")
- , testCase "" $ ("[1,2,3]" ^? nth 1) @?= Just (Number 2.0)
- , testCase "" $ ("{\"a\": 100, \"b\": 200}" ^? nth 1) @?= Nothing
- , testCase "" $ ("[1,2,3]" & nth 1 .~ Number 20) @?= "[1,20,3]"