summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/glib-tests-gapplication.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-12-03 22:51:18 +0100
committerLudovic Courtès <ludo@gnu.org>2014-12-03 22:52:19 +0100
commit36d2a3afeb9fba6f00de77cc62ef51e74380aff9 (patch)
tree5d9ff107f7d16416a4ec0d2b5b28502ca6819b69 /gnu/packages/patches/glib-tests-gapplication.patch
parentf2122ed1dc89353cad49a0ade54060d9946ba8d3 (diff)
gnu: glib: Work around unreliable GIO test.
Fixes <http://bugs.gnu.org/18445>. * gnu/packages/patches/glib-tests-gapplication.patch: New file * gnu/packages/glib.scm (glib)[source]: Add it. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches/glib-tests-gapplication.patch')
-rw-r--r--gnu/packages/patches/glib-tests-gapplication.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/patches/glib-tests-gapplication.patch b/gnu/packages/patches/glib-tests-gapplication.patch
new file mode 100644
index 0000000000..1845fcb9b8
--- /dev/null
+++ b/gnu/packages/patches/glib-tests-gapplication.patch
@@ -0,0 +1,28 @@
+This test has proven to be unreliable, often leading to things like this
+in gapplication.log:
+
+ PASS: gapplication 3 /gapplication/properties
+ Failed to register: The connection is closed
+ **
+ GLib-GIO:ERROR:gapplication.c:564:test_quit: assertion failed: (activated)
+ ok 4 /gapplication/app-id
+ PASS: gapplication 4 /gapplication/app-id
+ ../../tap-test: line 5: 24133 Aborted $1 -k --tap
+ # GLib-GIO:ERROR:gapplication.c:564:test_quit: assertion failed: (activated)
+ cleaning up pid 24154
+ ERROR: gapplication - missing test plan
+ ERROR: gapplication - exited with status 134 (terminated by signal 6?)
+
+See <https://bugs.debian.org/756273> and <http://bugs.gnu.org/18445>.
+
+
+--- glib-2.40.2/gio/tests/gapplication.c 2014-12-03 22:34:44.566667649 +0100
++++ glib-2.40.2/gio/tests/gapplication.c 2014-12-03 22:34:45.346674179 +0100
+@@ -685,7 +685,6 @@ main (int argc, char **argv)
+ /* g_test_add_func ("/gapplication/non-unique", test_nonunique); */
+ g_test_add_func ("/gapplication/properties", properties);
+ g_test_add_func ("/gapplication/app-id", appid);
+- g_test_add_func ("/gapplication/quit", test_quit);
+ g_test_add_func ("/gapplication/local-actions", test_local_actions);
+ /* g_test_add_func ("/gapplication/remote-actions", test_remote_actions); */
+ g_test_add_func ("/gapplication/local-command-line", test_local_command_line);