summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gnutls-skip-trust-store-test.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-06-10 15:47:00 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-06-11 01:08:58 +0200
commit88e2511e217f2c23c6048d6cf104df99be3fef63 (patch)
tree9a65d80a426ed6c0e04a9b5fbcb3c1fc10791174 /gnu/packages/patches/gnutls-skip-trust-store-test.patch
parente35dc5e75ea0fe98f9777f48715584b38b4cc302 (diff)
gnu: gnutls: Replace with 3.5.13.
This update addresses the following security advisories: GNUTLS-SA-2017-3 (aka CVE-2017-7869) and GNUTLS-SA-2017-4. See <https://gnutls.org/security.html> and <https://gnutls.org/news.html>. * gnu/packages/patches/gnutls-skip-pkgconfig-test.patch, gnu/packages/patches/gnutls-skip-trust-store-test.patch: New files. * gnu/local.mk (dist_patch_DATA): Register patches. * gnu/packages/tls.scm (gnutls)[replacement]: New field. (gnutls-3.5.13): New variable. (gnutls/guile-2.2)[replacement]: New field. Set #f. [source]: Inherit from GNUTLS-3.5.13.
Diffstat (limited to 'gnu/packages/patches/gnutls-skip-trust-store-test.patch')
-rw-r--r--gnu/packages/patches/gnutls-skip-trust-store-test.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/gnutls-skip-trust-store-test.patch b/gnu/packages/patches/gnutls-skip-trust-store-test.patch
new file mode 100644
index 0000000000..e0536712a5
--- /dev/null
+++ b/gnu/packages/patches/gnutls-skip-trust-store-test.patch
@@ -0,0 +1,15 @@
+Version 3.5.11 added a test to check that the default trust store is readable.
+It does not exist in the build environment, so pretend everything is fine.
+
+diff a/tests/trust-store.c b/tests/trust-store.c
+--- a/tests/trust-store.c
++++ b/tests/trust-store.c
+@@ -61,7 +61,7 @@
+ } else if (ret < 0) {
+ fail("error loading system trust store: %s\n", gnutls_strerror(ret));
+ } else if (ret == 0) {
+- fail("no certificates were found in system trust store!\n");
++ success("no trust store in the Guix build environment!\n");
+ }
+
+ gnutls_certificate_free_credentials(x509_cred);