summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-08-12 18:51:12 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-08-12 18:51:12 +0200
commitd08411ffd0a36a6b67a238be69d32c9f74101389 (patch)
treebdc5b0377106dcd9ae5f173120a888fc2fde5884 /gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch
parent60c4b012ff66680821381dcc5ae7f6073e61a7e2 (diff)
Revert "gnu: gobject-introspection: Update to 1.72.0."
This reverts commit 60c4b012ff66680821381dcc5ae7f6073e61a7e2. gobject-introspection was already updated to 1.72.0 prior to this patch.
Diffstat (limited to 'gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch')
-rw-r--r--gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch50
1 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch b/gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch
index ae75355bee..8bb86467c0 100644
--- a/gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch
+++ b/gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch
@@ -7,10 +7,10 @@ for 'gobject-introspection' 1.40.0 in Nix.
It has since been updated to work with newer versions of
gobject-introspection.
-Index: gobject-introspection-1.72.0/giscanner/scannermain.py
-===================================================================
---- gobject-introspection-1.72.0.orig/giscanner/scannermain.py
-+++ gobject-introspection-1.72.0/giscanner/scannermain.py
+diff --git a/giscanner/scannermain.py b/giscanner/scannermain.py
+index 1d39ab84..e12ed24e 100644
+--- a/giscanner/scannermain.py
++++ b/giscanner/scannermain.py
@@ -95,6 +95,39 @@ def get_windows_option_group(parser):
return group
@@ -51,21 +51,21 @@ Index: gobject-introspection-1.72.0/giscanner/scannermain.py
def _get_option_parser():
parser = optparse.OptionParser('%prog [options] sources',
version='%prog ' + giscanner.__version__)
-@@ -217,6 +250,10 @@ match the namespace prefix.""")
- parser.add_option("", "--filelist",
- action="store", dest="filelist", default=[],
- help="file containing headers and sources to be scanned")
+@@ -220,6 +253,10 @@ match the namespace prefix.""")
+ parser.add_option("", "--compiler",
+ action="store", dest="compiler", default=None,
+ help="the C compiler to use internally")
+ parser.add_option("", "--fallback-library-path",
+ action="store", dest="fallback_libpath",
+ default=_get_default_fallback_libpath(),
+ help="Path to prepend to unknown shared libraries")
- parser.add_option("", "--compiler",
- action="store", dest="compiler", default=None,
- help="the C compiler to use internally")
-Index: gobject-introspection-1.72.0/giscanner/shlibs.py
-===================================================================
---- gobject-introspection-1.72.0.orig/giscanner/shlibs.py
-+++ gobject-introspection-1.72.0/giscanner/shlibs.py
+
+ group = get_preprocessor_option_group(parser)
+ parser.add_option_group(group)
+diff --git a/giscanner/shlibs.py b/giscanner/shlibs.py
+index 9f8ab5df..8aa37c99 100644
+--- a/giscanner/shlibs.py
++++ b/giscanner/shlibs.py
@@ -57,6 +57,14 @@ def _ldd_library_pattern(library_name):
$""" % re.escape(library_name), re.VERBOSE)
@@ -81,7 +81,7 @@ Index: gobject-introspection-1.72.0/giscanner/shlibs.py
# This is a what we do for non-la files. We assume that we are on an
# ELF-like system where ldd exists and the soname extracted with ldd is
# a filename that can be opened with dlopen().
-@@ -108,7 +116,8 @@ def _resolve_non_libtool(options, binary
+@@ -108,7 +116,8 @@ def _resolve_non_libtool(options, binary, libraries):
output = output.decode("utf-8", "replace")
shlibs = resolve_from_ldd_output(libraries, output)
@@ -116,7 +116,7 @@ Index: gobject-introspection-1.72.0/giscanner/shlibs.py
if len(patterns) == 0:
return []
-@@ -141,8 +149,12 @@ def resolve_from_ldd_output(libraries, o
+@@ -141,8 +149,12 @@ def resolve_from_ldd_output(libraries, output):
if line.endswith(':'):
continue
for word in line.split():
@@ -131,10 +131,10 @@ Index: gobject-introspection-1.72.0/giscanner/shlibs.py
if m:
del patterns[library]
shlibs.append(m.group())
-Index: gobject-introspection-1.72.0/giscanner/utils.py
-===================================================================
---- gobject-introspection-1.72.0.orig/giscanner/utils.py
-+++ gobject-introspection-1.72.0/giscanner/utils.py
+diff --git a/giscanner/utils.py b/giscanner/utils.py
+index 31c7ea48..630002a8 100644
+--- a/giscanner/utils.py
++++ b/giscanner/utils.py
@@ -114,16 +114,11 @@ def extract_libtool_shlib(la_file):
if dlname is None:
return None
@@ -157,10 +157,10 @@ Index: gobject-introspection-1.72.0/giscanner/utils.py
# Returns arguments for invoking libtool, if applicable, otherwise None
-Index: gobject-introspection-1.72.0/tests/scanner/test_shlibs.py
-===================================================================
---- gobject-introspection-1.72.0.orig/tests/scanner/test_shlibs.py
-+++ gobject-introspection-1.72.0/tests/scanner/test_shlibs.py
+diff --git a/tests/scanner/test_shlibs.py b/tests/scanner/test_shlibs.py
+index a8337c60..7f123103 100644
+--- a/tests/scanner/test_shlibs.py
++++ b/tests/scanner/test_shlibs.py
@@ -40,7 +40,8 @@ class TestLddParser(unittest.TestCase):
self.assertEqual(