summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gobject-introspection-cc.patch
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-09-07 17:31:44 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-09-07 18:05:57 -0400
commit426038df3b4a00fc3c4a3997c4014ac6da5192cf (patch)
tree0a6fe6eb815e45a06bd1868085256e1608e3748c /gnu/packages/patches/gobject-introspection-cc.patch
parent693d75e859150601145b7f7303f61d4f48e76927 (diff)
gnu: gobject-introspection: Update to 1.68.0 and adjust patches.
* gnu/packages/glib.scm (gobject-introspection)[version]: Update to 1.68.0. * gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch: Modify. * gnu/packages/patches/gobject-introspection-cc.patch: Modify.
Diffstat (limited to 'gnu/packages/patches/gobject-introspection-cc.patch')
-rw-r--r--gnu/packages/patches/gobject-introspection-cc.patch23
1 files changed, 17 insertions, 6 deletions
diff --git a/gnu/packages/patches/gobject-introspection-cc.patch b/gnu/packages/patches/gobject-introspection-cc.patch
index 6a86b56b44..fde13d1a59 100644
--- a/gnu/packages/patches/gobject-introspection-cc.patch
+++ b/gnu/packages/patches/gobject-introspection-cc.patch
@@ -1,14 +1,25 @@
-Use gcc as the default C compiler if CC is not set.
+From e9b8fa0768a1f0ef7df2659eb559f48433ff82be Mon Sep 17 00:00:00 2001
+From: Raghav Gururajan <rg@raghavgururajan.name>
+Date: Tue, 7 Sep 2021 16:59:16 -0400
+Subject: Use gcc as the default C compiler if CC is not set.
-diff -ru gobject-introspection-1.58.1.orig/giscanner/__init__.py gobject-introspection-1.58.1/giscanner/__init__.py
---- gobject-introspection-1.58.1.orig/giscanner/__init__.py 1970-01-01 01:00:00.000000000 +0100
-+++ gobject-introspection-1.58.1/giscanner/__init__.py 2018-12-03 13:33:28.788971299 +0100
-@@ -22,6 +22,8 @@
+---
+ giscanner/__init__.py | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/giscanner/__init__.py b/giscanner/__init__.py
+index 7c2f365a..607fe341 100644
+--- a/giscanner/__init__.py
++++ b/giscanner/__init__.py
+@@ -21,6 +21,8 @@ import os
builddir = os.environ.get('UNINSTALLED_INTROSPECTION_BUILDDIR')
if builddir is not None:
- __path__.append(os.path.join(builddir, 'giscanner'))
+ __path__.append(os.path.join(builddir, 'giscanner')) # type: ignore # mypy issue #1422
+if not 'CC' in os.environ:
+ os.environ['CC'] = 'gcc'
try:
from ._version import __version__
except ImportError:
+--
+2.33.0
+