summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gsl-poly-test-fix-pt2.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-06-20 01:38:56 -0400
committerMark H Weaver <mhw@netris.org>2015-06-20 01:38:56 -0400
commit180a93c72a69e6e322da1226c4d439a321279490 (patch)
treee17b44767df911fa4058395ec5b9d35466a77a30 /gnu/packages/patches/gsl-poly-test-fix-pt2.patch
parentd80b0d4af54c56a2628ee285631cdcce2b21fd58 (diff)
gnu: gsl: Fix poly test on i686.
* gnu/packages/patches/gsl-poly-test-fix-pt1.patch, gnu/packages/patches/gsl-poly-test-fix-pt2.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/maths.scm (gsl)[source]: Add patches.
Diffstat (limited to 'gnu/packages/patches/gsl-poly-test-fix-pt2.patch')
-rw-r--r--gnu/packages/patches/gsl-poly-test-fix-pt2.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/patches/gsl-poly-test-fix-pt2.patch b/gnu/packages/patches/gsl-poly-test-fix-pt2.patch
new file mode 100644
index 0000000000..0e6fcf1a53
--- /dev/null
+++ b/gnu/packages/patches/gsl-poly-test-fix-pt2.patch
@@ -0,0 +1,27 @@
+From 0466df8660a7b6ddf2e082a1ec38bc6ea25a3c5c Mon Sep 17 00:00:00 2001
+From: Patrick Alken <alken@colorado.edu>
+Date: Mon, 7 Apr 2014 10:59:58 -0600
+Subject: [PATCH] change error test for 15th degree polynomial (bug #39055)
+
+---
+ poly/test.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/poly/test.c b/poly/test.c
+index d090802..f6a7e3f 100644
+--- a/poly/test.c
++++ b/poly/test.c
+@@ -579,8 +579,8 @@ main (void)
+
+ for (i = 0; i<15; i++)
+ {
+- gsl_test_abs (z[2*i], expected[2*i], 1e-7, "z%d.real, 15th-order polynomial", i);
+- gsl_test_abs (z[2*i+1], expected[2*i+1], 1e-7, "z%d.imag, 15th-order polynomial", i);
++ gsl_test_rel (z[2*i], expected[2*i], 1e-7, "z%d.real, 15th-order polynomial", i);
++ gsl_test_rel (z[2*i+1], expected[2*i+1], 1e-7, "z%d.imag, 15th-order polynomial", i);
+ }
+ }
+
+--
+2.4.3
+