summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gtk3-respect-GUIX_GTK3_PATH.patch
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-12-03 08:32:06 +0100
committerMark H Weaver <mhw@netris.org>2016-01-04 16:11:10 -0500
commit4828ff91ffa937fa6cb1618fcab550c137e60f15 (patch)
tree3b43b0a7422b5952eaceef565b4e07ba37f94ec7 /gnu/packages/patches/gtk3-respect-GUIX_GTK3_PATH.patch
parent2a6afac9055bc2cac29678b9e2ed0344cb32c39e (diff)
gnu: gtk+: Add patch to support GUIX_GTK3_PATH.
* gnu/packages/patches/gtk3-respect-GUIX_GTK3_PATH: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/gtk.scm (gtk+) [source]: Add patch. [native-search-paths]: Add search path for GUIX_GTK3_PATH.
Diffstat (limited to 'gnu/packages/patches/gtk3-respect-GUIX_GTK3_PATH.patch')
-rw-r--r--gnu/packages/patches/gtk3-respect-GUIX_GTK3_PATH.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/patches/gtk3-respect-GUIX_GTK3_PATH.patch b/gnu/packages/patches/gtk3-respect-GUIX_GTK3_PATH.patch
new file mode 100644
index 0000000000..66fd2fd1c4
--- /dev/null
+++ b/gnu/packages/patches/gtk3-respect-GUIX_GTK3_PATH.patch
@@ -0,0 +1,38 @@
+This patch makes GTK+ look for additional modules in a list of directories
+specified by the environment variable "GUIX_GTK3_PATH". This can be used
+instead of "GTK_PATH" to make GTK+ find modules that are incompatible with
+other major versions of GTK+.
+
+--- a/gtk/gtkmodules.c 2015-09-20 20:09:05.060590217 +0200
++++ b/gtk/gtkmodules.c 2015-09-20 20:10:33.423124833 +0200
+@@ -52,6 +52,7 @@
+ get_module_path (void)
+ {
+ const gchar *module_path_env;
++ const gchar *module_guix_gtk3_path_env;
+ const gchar *exe_prefix;
+ gchar *module_path;
+ gchar *default_dir;
+@@ -61,6 +62,7 @@
+ return result;
+
+ module_path_env = g_getenv ("GTK_PATH");
++ module_guix_gtk3_path_env = g_getenv ("GUIX_GTK3_PATH");
+ exe_prefix = g_getenv ("GTK_EXE_PREFIX");
+
+ if (exe_prefix)
+@@ -68,7 +70,13 @@
+ else
+ default_dir = g_build_filename (_gtk_get_libdir (), "gtk-3.0", NULL);
+
+- if (module_path_env)
++ if (module_guix_gtk3_path_env && module_path_env)
++ module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
++ module_guix_gtk3_path_env, module_path_env, default_dir, NULL);
++ else if (module_guix_gtk3_path_env)
++ module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
++ module_guix_gtk3_path_env, default_dir, NULL);
++ else if (module_path_env)
+ module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
+ module_path_env, default_dir, NULL);
+ else