summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/guile-3.0-crash.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-10 20:50:02 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-10 20:50:02 +0100
commit50b99c90c87642f664f9c9523a6e40fc8542ddcf (patch)
tree9fc8845e93ba913730e5fb92bbad158716d84e74 /gnu/packages/patches/guile-3.0-crash.patch
parentbda4b5e0453e4c8feda24306b4aa76ad5406eb7d (diff)
parent21656ffa3b6d78a610f0befced20cc9b4b3baab6 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches/guile-3.0-crash.patch')
-rw-r--r--gnu/packages/patches/guile-3.0-crash.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/guile-3.0-crash.patch b/gnu/packages/patches/guile-3.0-crash.patch
new file mode 100644
index 0000000000..510834ab57
--- /dev/null
+++ b/gnu/packages/patches/guile-3.0-crash.patch
@@ -0,0 +1,17 @@
+Fix crash due to: <https://issues.guix.gnu.org/issue/39266>.
+
+diff --git a/libguile/struct.c b/libguile/struct.c
+index 3dbcc71d4..ddcbe46d2 100644
+--- a/libguile/struct.c
++++ b/libguile/struct.c
+@@ -139,7 +139,9 @@ set_vtable_access_fields (SCM vtable)
+ nfields = len / 2;
+
+ bitmask_size = (nfields + 31U) / 32U;
+- unboxed_fields = scm_gc_malloc_pointerless (bitmask_size, "unboxed fields");
++ unboxed_fields =
++ scm_gc_malloc_pointerless (bitmask_size * sizeof (*unboxed_fields),
++ "unboxed fields");
+ memset (unboxed_fields, 0, bitmask_size * sizeof(*unboxed_fields));
+
+ /* Update FLAGS according to LAYOUT. */