summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/guile-bytestructures-name-clash.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-07-25 17:06:51 +0200
committerLudovic Courtès <ludo@gnu.org>2017-07-25 17:46:17 +0200
commit726ecfeb3ae9eb4baacf042e2dd34b1e377dccfa (patch)
tree7a90b6472187e2a5bb97362de5ee6314a5df312f /gnu/packages/patches/guile-bytestructures-name-clash.patch
parent0093b1262b1af6b66cf255112bdad7ed6f8f08e3 (diff)
gnu: Add guile2.0-bytestructures.
* gnu/packages/patches/guile-bytestructures-name-clash.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/guile.scm (guile-bytestructures)[source]: Use it. [arguments]: Unpack the source. [native-inputs]: New field. (guile2.0-bytestructures): New variable.
Diffstat (limited to 'gnu/packages/patches/guile-bytestructures-name-clash.patch')
-rw-r--r--gnu/packages/patches/guile-bytestructures-name-clash.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/patches/guile-bytestructures-name-clash.patch b/gnu/packages/patches/guile-bytestructures-name-clash.patch
new file mode 100644
index 0000000000..ac834dd504
--- /dev/null
+++ b/gnu/packages/patches/guile-bytestructures-name-clash.patch
@@ -0,0 +1,31 @@
+This patch works around a name clash between the 'cstring-pointer' module and
+the 'cstring-module' variable that occurs in Guile 2.0:
+
+ ice-9/boot-9.scm:109:20: re-exporting local variable: cstring-pointer
+
+--- guile-bytestructures-20170402.91d042e-checkout/bytestructures/guile.scm 2017-07-25 17:04:32.858289986 +0200
++++ guile-bytestructures-20170402.91d042e-checkout/bytestructures/guile.scm 2017-07-25 17:04:41.130244725 +0200
+@@ -1,6 +1,6 @@
+ (define-module (bytestructures guile))
+
+-(import
++(use-modules
+ (bytestructures guile base)
+ (bytestructures guile vector)
+ (bytestructures guile struct)
+@@ -8,7 +8,7 @@
+ (bytestructures guile pointer)
+ (bytestructures guile numeric)
+ (bytestructures guile string)
+- (bytestructures guile cstring-pointer))
++ ((bytestructures guile cstring-pointer) #:prefix cstr:))
+ (re-export
+ make-bytestructure-descriptor
+ bytestructure-descriptor?
+@@ -75,5 +75,5 @@
+
+ bs:string
+
+- cstring-pointer
++ cstr:cstring-pointer
+ )