summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ibus-anthy-fix-tests.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-22 10:45:11 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-22 12:34:20 -0400
commit13425768f7c393cda49302ba2e8705f14ae56f0d (patch)
tree4f3bb4c06b4dee4b59c5585272e1450d021ccd4c /gnu/packages/patches/ibus-anthy-fix-tests.patch
parent206b357c01b35a3aabbcfb2b69c5102d96723916 (diff)
gnu: ibus-anthy: Update to 1.5.15.
* gnu/packages/ibus.scm (ibus-anthy): Update to 1.5.15. * gnu/packages/patches/ibus-anthy-fix-tests.patch: Update patch.
Diffstat (limited to 'gnu/packages/patches/ibus-anthy-fix-tests.patch')
-rw-r--r--gnu/packages/patches/ibus-anthy-fix-tests.patch16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/patches/ibus-anthy-fix-tests.patch b/gnu/packages/patches/ibus-anthy-fix-tests.patch
index 6934358980..c8b2b4211e 100644
--- a/gnu/packages/patches/ibus-anthy-fix-tests.patch
+++ b/gnu/packages/patches/ibus-anthy-fix-tests.patch
@@ -1,17 +1,14 @@
Submitted upstream: https://github.com/ibus/ibus-anthy/pull/35
diff --git a/tests/test-build.sh b/tests/test-build.sh
-index e83b78f..a0efe32 100755
+index e83b78f..bbfa7e1 100755
--- a/tests/test-build.sh
+++ b/tests/test-build.sh
-@@ -63,26 +63,27 @@ parse_args()
+@@ -63,26 +63,33 @@ parse_args()
done;
}
+maybe_install_pycotap() {
-+ # Check if pycotap is already available.
-+ python3 -m pycotap >/dev/null && return 0
-+
+ # Red Hat specific hint.
+ if test -f /etc/redhat-release ; then
+ if ! rpm -q --quiet python3-pycotap; then
@@ -19,6 +16,15 @@ index e83b78f..a0efe32 100755
+ exit -1
+ fi
+ fi;
++
++ # Check if pycotap is already available.
++ if ! python3 -m pycotap >/dev/null; then
++ echo "pycotap not found; installing via pip"
++ if ! pip install pycotap --user; then
++ echo "failed to install pycotap"
++ exit -1
++ fi
++ fi
+}
+
init_environment()