summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/icecat-CVE-2015-4488.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-08-12 17:41:15 -0400
committerMark H Weaver <mhw@netris.org>2015-08-12 20:37:44 -0400
commitc037a0f7ce79d8d67e08694ae20e407b1280d84e (patch)
tree60e6810db94ef46a96682ed2bd80acdec23b5fff /gnu/packages/patches/icecat-CVE-2015-4488.patch
parentf74c577ce08399106a7ed4abe1b7d26e82fefd10 (diff)
gnu: icecat: Add fixes for CVE-2015-{4473,4482,4488,4489,4491,4492}.
WARNING: CVE-2015-4473 may not be fully addressed here, because I was unable to backport some of the patches (for upstream bugs 1182711 and 1146213). I was also unable to backport CVE-2015-4484 (upstream bug 1171540) and CVE-2015-4487 (upstream bug 1171603). I was unable to find any commit in the upstream repository that claims to address bug 1105914 (CVE-2015-4478). * gnu/packages/patches/icecat-CVE-2015-4473-partial.patch, gnu/packages/patches/icecat-CVE-2015-4482.patch, gnu/packages/patches/icecat-CVE-2015-4488.patch, gnu/packages/patches/icecat-CVE-2015-4489.patch, gnu/packages/patches/icecat-CVE-2015-4491.patch, gnu/packages/patches/icecat-CVE-2015-4492.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/gnuzilla.scm (icecat)[source]: Add patches.
Diffstat (limited to 'gnu/packages/patches/icecat-CVE-2015-4488.patch')
-rw-r--r--gnu/packages/patches/icecat-CVE-2015-4488.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/patches/icecat-CVE-2015-4488.patch b/gnu/packages/patches/icecat-CVE-2015-4488.patch
new file mode 100644
index 0000000000..cee0905be0
--- /dev/null
+++ b/gnu/packages/patches/icecat-CVE-2015-4488.patch
@@ -0,0 +1,21 @@
+Backported to icecat-31.8 from the upstream esr38 branch.
+
+From 103fb14ff54753305508448ba0e374247a463552 Mon Sep 17 00:00:00 2001
+From: Daniel Holbert <dholbert@cs.stanford.edu>
+Date: Fri, 19 Jun 2015 15:56:12 -0700
+Subject: [PATCH] Bug 1176270 - Handle self-assignment in
+ StyleAnimationValue::operator=. r=dbaron, a=sledru
+
+--- icecat-31.8.0/layout/style/nsStyleAnimation.cpp.orig 1969-12-31 19:00:00.000000000 -0500
++++ icecat-31.8.0/layout/style/nsStyleAnimation.cpp 2015-08-12 16:00:39.418122049 -0400
+@@ -3517,6 +3517,10 @@
+ nsStyleAnimation::Value&
+ nsStyleAnimation::Value::operator=(const Value& aOther)
+ {
++ if (this == &aOther) {
++ return *this;
++ }
++
+ FreeValue();
+
+ mUnit = aOther.mUnit;