summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ldc-1.7.0-disable-phobos-tests.patch
diff options
context:
space:
mode:
authorPjotr Prins <pjotr.public01@thebird.nl>2018-02-18 06:09:44 +0000
committerDanny Milosavljevic <dannym@scratchpost.org>2018-02-20 19:36:34 +0100
commit1b541c3e9375952f4d58dec3783eea2316c65967 (patch)
treeed54107a139e07dbdf15d918c839a2090b5464fd /gnu/packages/patches/ldc-1.7.0-disable-phobos-tests.patch
parent5dd53cbf560f784577b3c22ac9e15e08e35566b5 (diff)
gnu: ldc: Update to 1.7.0.
Fixes recent bootstrap and updates ldc and package manager to match. * gnu/packages/ldc.scm (ldc-bootstrap): Update to 0.17.4. [properties]: Add max-slient-time. [arguments]<#:phases>[patch-phobos]: Update patches (see below). (ldc): Update to 1.7.0. (ldc-beta): Delete variable. [arguments]<#:phases>[patch-phobos]: Update patches (see below). [arguments]<#:phases>[check]: Use invoke. (rdmd): Update to 2.077.1. (dub): Update to 1.7.2. * gnu/local.mk (dist_patch_DATA): Remove "ldc-disable-tests.patch". Add "ldc-bootstrap-disable-tests.patch". Remove "ldc-1.1.0-disable-phobos-tests.patch". Add "ldc-1.7.0-disable-phobos-tests.patch". Remove "ldc-1.1.0-disable-dmd-tests.patch". Co-Authored-By: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/patches/ldc-1.7.0-disable-phobos-tests.patch')
-rw-r--r--gnu/packages/patches/ldc-1.7.0-disable-phobos-tests.patch88
1 files changed, 88 insertions, 0 deletions
diff --git a/gnu/packages/patches/ldc-1.7.0-disable-phobos-tests.patch b/gnu/packages/patches/ldc-1.7.0-disable-phobos-tests.patch
new file mode 100644
index 0000000000..ccc136cc76
--- /dev/null
+++ b/gnu/packages/patches/ldc-1.7.0-disable-phobos-tests.patch
@@ -0,0 +1,88 @@
+diff --git a/std/path.d b/std/path.d
+index a9f0bd8..f47d103 100644
+--- a/std/path.d
++++ b/std/path.d
+@@ -4041,7 +4041,7 @@ version(unittest) import std.process : environment;
+ else version (Android)
+ {
+ }
+- else
++ else version (HasRoot)
+ {
+ assert(expandTilde("~root") == "/root", expandTilde("~root"));
+ assert(expandTilde("~root/") == "/root/", expandTilde("~root/"));
+
+diff --git a/std/process.d b/std/process.d
+index df83296..d921cdb 100644
+--- a/std/process.d
++++ b/std/process.d
+@@ -1171,7 +1171,7 @@ version (Posix) @system unittest
+ assert(exists(buildPath(directory, "bar")));
+ }
+
+-@system unittest // Specifying a bad working directory.
++@system version(skipunittest) unittest // Specifying a bad working directory.
+ {
+ import std.exception : assertThrown;
+ TestScript prog = "/bin/echo";
+diff --git a/std/socket.d b/std/socket.d
+index 8a261d5..c1b87b6 100644
+--- a/std/socket.d
++++ b/std/socket.d
+@@ -484,7 +484,7 @@ class Protocol
+ // Skip this test on Android because getprotobyname/number are
+ // unimplemented in bionic.
+ version(CRuntime_Bionic) {} else
+-@safe unittest
++@safe version(hasNetwork) unittest
+ {
+ softUnittest({
+ Protocol proto = new Protocol;
+@@ -804,7 +804,7 @@ class InternetHost
+ }
+
+ ///
+-@safe unittest
++@safe version(hasNetwork) unittest
+ {
+ InternetHost ih = new InternetHost;
+
+@@ -959,7 +959,7 @@ AddressInfo[] getAddressInfo(T...)(in char[] node, T options)
+ return () @trusted { return getAddressInfoImpl(node, service, &hints); }();
+ }
+
+-@system unittest
++@system version(hasNetwork) unittest
+ {
+ struct Oops
+ {
+@@ -1010,7 +1010,7 @@ private AddressInfo[] getAddressInfoImpl(in char[] node, in char[] service, addr
+ }
+
+
+-@safe unittest
++@safe version(hasNetwork) unittest
+ {
+ softUnittest({
+ if (getaddrinfoPointer)
+diff --git a/std/stdio.d b/std/stdio.d
+index 10106a5..4b0590e 100644
+--- a/std/stdio.d
++++ b/std/stdio.d
+@@ -1426,8 +1426,7 @@ Removes the lock over the specified file segment.
+ g.unlock();
+ }
+
+- version(Posix)
+- @system unittest
++ @system version(skip) unittest
+ {
+ static import std.file;
+ auto deleteme = testFilename();
+@@ -1483,7 +1482,6 @@ Removes the lock over the specified file segment.
+ f.unlock();
+ }
+
+-
+ /**
+ Writes its arguments in text format to the file.