summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/libextractor-CVE-2018-20430.patch
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-03-14 10:43:47 +0000
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-18 15:05:08 +0100
commita3f2c295e7f8719dc47d5757b89188e0ed68faf2 (patch)
treecc56265e65362b54605e611d24dea091b59c5db3 /gnu/packages/patches/libextractor-CVE-2018-20430.patch
parent47956fa0c24efcdcba3493f0231c30e9a39ec7df (diff)
gnu: libextractor: Update to 1.9.
* gnu/packages/gnunet (libextractor): Update to 1.9. [source]: Remove patches. * gnu/packages/patches/libextractor-CVE-2018-20430.patch gnu/packages/patches/libextractor-CVE-2018-20431.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/patches/libextractor-CVE-2018-20430.patch')
-rw-r--r--gnu/packages/patches/libextractor-CVE-2018-20430.patch60
1 files changed, 0 insertions, 60 deletions
diff --git a/gnu/packages/patches/libextractor-CVE-2018-20430.patch b/gnu/packages/patches/libextractor-CVE-2018-20430.patch
deleted file mode 100644
index 570cd7c006..0000000000
--- a/gnu/packages/patches/libextractor-CVE-2018-20430.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-Fix CVE-2018-20430:
-
-https://gnunet.org/bugs/view.php?id=5493
-https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-20430
-https://security-tracker.debian.org/tracker/CVE-2018-20430
-
-Patch copied from upstream source repository:
-
-https://gnunet.org/git/libextractor.git/commit/?id=b405d707b36e0654900cba78e89f49779efea110
-
-From b405d707b36e0654900cba78e89f49779efea110 Mon Sep 17 00:00:00 2001
-From: Christian Grothoff <christian@grothoff.org>
-Date: Thu, 20 Dec 2018 22:47:53 +0100
-Subject: [PATCH] fix #5493 (out of bounds read)
-
----
- src/common/convert.c | 10 +++++-----
- 1 file changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/src/common/convert.c b/src/common/convert.c
-index c0edf21..2be2108 100644
---- a/src/common/convert.c
-+++ b/src/common/convert.c
-@@ -36,8 +36,8 @@
- * string is returned.
- */
- char *
--EXTRACTOR_common_convert_to_utf8 (const char *input,
-- size_t len,
-+EXTRACTOR_common_convert_to_utf8 (const char *input,
-+ size_t len,
- const char *charset)
- {
- #if HAVE_ICONV
-@@ -52,7 +52,7 @@ EXTRACTOR_common_convert_to_utf8 (const char *input,
- i = input;
- cd = iconv_open ("UTF-8", charset);
- if (cd == (iconv_t) - 1)
-- return strdup (i);
-+ return strndup (i, len);
- if (len > 1024 * 1024)
- {
- iconv_close (cd);
-@@ -67,11 +67,11 @@ EXTRACTOR_common_convert_to_utf8 (const char *input,
- }
- itmp = tmp;
- finSize = tmpSize;
-- if (iconv (cd, (char **) &input, &len, &itmp, &finSize) == SIZE_MAX)
-+ if (iconv (cd, (char **) &input, &len, &itmp, &finSize) == ((size_t) -1))
- {
- iconv_close (cd);
- free (tmp);
-- return strdup (i);
-+ return strndup (i, len);
- }
- ret = malloc (tmpSize - finSize + 1);
- if (ret == NULL)
---
-2.20.1
-