summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/libftdi-fix-paths-when-FTDIPP-set.patch
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2023-09-07 12:37:57 -0400
committerLudovic Courtès <ludo@gnu.org>2023-09-14 23:37:19 +0200
commit6c4868aca9e098fd7c830ba681ae0735aa752bdd (patch)
tree2dc94f188c7866cd4117579be772598c2a28e257 /gnu/packages/patches/libftdi-fix-paths-when-FTDIPP-set.patch
parent856eeedcbc65add655a40878ebed81aecd44a377 (diff)
gnu: libftdi: Update to 1.5.
* gnu/packages/patches/libftdi-fix-paths-when-FTDIPP-set.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/libftdi.scm (libftdi): Update to 1.5. [source]: Apply patch. [arguments]<#:configure-flags>: Add "-DFTDIPP", "-DPYTHON_BINDINGS". Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/libftdi-fix-paths-when-FTDIPP-set.patch')
-rw-r--r--gnu/packages/patches/libftdi-fix-paths-when-FTDIPP-set.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/patches/libftdi-fix-paths-when-FTDIPP-set.patch b/gnu/packages/patches/libftdi-fix-paths-when-FTDIPP-set.patch
new file mode 100644
index 0000000000..0a81cceb26
--- /dev/null
+++ b/gnu/packages/patches/libftdi-fix-paths-when-FTDIPP-set.patch
@@ -0,0 +1,39 @@
+commit cdb28383402d248dbc6062f4391b038375c52385
+Author: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+Date: Fri Jul 17 21:25:03 2020 +0200
+
+ CMakeLists.txt: fix paths when FTDIPP is set
+
+ Use the same project name (i.e. libftdi1 and not libftdipp1) when FTDIPP
+ is enabled as suggested by Aurelien Jarno in
+ http://developer.intra2net.com/mailarchive/html/libftdi/2020/msg00044.html
+
+ Without this change, the libftdi1.pc config file defines the include
+ path as /usr/local/include/libftdipp1 while the ftdi.h file is actually
+ installed in /usr/local/include/libftdi1
+
+ This is an issue for example for libsigrok which will fail on:
+
+ In file included from src/hardware/asix-sigma/protocol.c:27:
+ src/hardware/asix-sigma/protocol.h:28:10: fatal error: ftdi.h: No such file or directory
+ 28 | #include <ftdi.h>
+ | ^~~~~~~~
+
+ Fixes:
+ - http://autobuild.buildroot.org/results/1427f44e36752c337791597fab47a1889552a2fe
+
+ Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 5aecafc..3b0b87c 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -136,7 +136,7 @@ endif ()
+
+ add_subdirectory(src)
+ if ( FTDIPP )
+- project(libftdipp1 C CXX)
++ project(libftdi1 C CXX)
+ add_subdirectory(ftdipp)
+ endif ()
+ if ( PYTHON_BINDINGS )