summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/libtirpc-missing-headers.patch
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-01-03 15:36:25 -0500
committerLeo Famulari <leo@famulari.name>2018-01-10 00:07:39 -0800
commite5227712213719d57a556418a675db0b838c040c (patch)
treeb82f3e03186a28162b6634a15f361b32ab112ca3 /gnu/packages/patches/libtirpc-missing-headers.patch
parent64a153bd1a81bd50f259553188edb2464221bb34 (diff)
gnu: libtirpc: Update to 1.0.2.
* gnu/packages/onc-rpc.scm (libtirpc): Update to 1.0.2. [source]: Adjust patch list. * gnu/packages/patches/libtirpc-CVE-2017-8779.patch: Delete file. * gnu/packages/patches/libtirpc-missing-headers.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/patches/libtirpc-missing-headers.patch')
-rw-r--r--gnu/packages/patches/libtirpc-missing-headers.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/patches/libtirpc-missing-headers.patch b/gnu/packages/patches/libtirpc-missing-headers.patch
new file mode 100644
index 0000000000..5a96711820
--- /dev/null
+++ b/gnu/packages/patches/libtirpc-missing-headers.patch
@@ -0,0 +1,40 @@
+Fix compilation failure with glibc 2.26 caused by missing type
+declarations:
+
+------
+xdr_sizeof.c: In function ‘x_inline’:
+xdr_sizeof.c:93:13: error: ‘uintptr_t’ undeclared (first use in this function)
+ if (len < (uintptr_t)xdrs->x_base) {
+------
+
+Patch copied from upstream source repository:
+
+http://git.linux-nfs.org/?p=steved/libtirpc.git;a=commit;h=acb9a37977cf0a9630eac74af9adebf35e38e719
+
+From acb9a37977cf0a9630eac74af9adebf35e38e719 Mon Sep 17 00:00:00 2001
+From: Thorsten Kukuk <kukuk@thkukuk.de>
+Date: Tue, 14 Nov 2017 10:39:08 -0500
+Subject: [PATCH] Include stdint.h from xdr_sizeof.c to avoid missing
+ declaration errors.
+
+Signed-off-by: Thorsten Kukuk <kukuk@suse.de>
+Signed-off-by: Steve Dickson <steved@redhat.com>
+---
+ src/xdr_sizeof.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/xdr_sizeof.c b/src/xdr_sizeof.c
+index d23fbd1..79d6707 100644
+--- a/src/xdr_sizeof.c
++++ b/src/xdr_sizeof.c
+@@ -39,6 +39,7 @@
+ #include <rpc/xdr.h>
+ #include <sys/types.h>
+ #include <stdlib.h>
++#include <stdint.h>
+ #include "un-namespace.h"
+
+ /* ARGSUSED */
+--
+1.8.3.1
+