summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/lsh-no-root-login.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-18 01:06:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-18 01:07:31 +0100
commit1ffa7090b99dfd2f54fa883929c5e78d7852657a (patch)
tree1c8bd191e31212e172b3e9158408cccd571a5020 /gnu/packages/patches/lsh-no-root-login.patch
parent08ba7ff318720d926215de83daed0da628908ca3 (diff)
distro: Change the module name space to (gnu ...).
* distro: Rename to... * gnu: ... this. Update module names accordingly. * Makefile.am: Adjust accordingly. * po/POTFILES.in: Likewise. * distro.scm: Search for files under /gnu/packages instead of /distro/packages. * gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
Diffstat (limited to 'gnu/packages/patches/lsh-no-root-login.patch')
-rw-r--r--gnu/packages/patches/lsh-no-root-login.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/lsh-no-root-login.patch b/gnu/packages/patches/lsh-no-root-login.patch
new file mode 100644
index 0000000000..9dd81de3fb
--- /dev/null
+++ b/gnu/packages/patches/lsh-no-root-login.patch
@@ -0,0 +1,16 @@
+Correctly handle the `--no-root-login' option.
+
+--- lsh-2.0.4/src/lshd.c 2006-05-01 13:47:44.000000000 +0200
++++ lsh-2.0.4/src/lshd.c 2009-09-08 12:20:36.000000000 +0200
+@@ -758,6 +758,10 @@ main_argp_parser(int key, char *arg, str
+ self->allow_root = 1;
+ break;
+
++ case OPT_NO_ROOT_LOGIN:
++ self->allow_root = 0;
++ break;
++
+ case OPT_KERBEROS_PASSWD:
+ self->pw_helper = PATH_KERBEROS_HELPER;
+ break;
+