summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/maturin-no-cross-compile.patch
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-08-06 10:22:00 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:38:26 +0300
commitc08da95daed1c9af66b18c82dd87c8a58d98bb2d (patch)
treee21339b6ad12e537eb34265cd94dc8acf107e4eb /gnu/packages/patches/maturin-no-cross-compile.patch
parent3cb37724ffdc40bf3665fe7f17c0ac075b3b4aae (diff)
gnu: Add maturin.
* gnu/packages/rust-apps.scm (maturin): New variable. * gnu/packages/patches/maturin-no-cross-compile.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/patches/maturin-no-cross-compile.patch')
-rw-r--r--gnu/packages/patches/maturin-no-cross-compile.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnu/packages/patches/maturin-no-cross-compile.patch b/gnu/packages/patches/maturin-no-cross-compile.patch
new file mode 100644
index 0000000000..7394d0854e
--- /dev/null
+++ b/gnu/packages/patches/maturin-no-cross-compile.patch
@@ -0,0 +1,55 @@
+Remove dependencies on xwin and zig. We're not offering cross-compilation
+options using these crates.
+
+diff --git a/Cargo.toml b/Cargo.toml
+index 6cbdca3..22ea5ef 100644
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -76,16 +76,6 @@ version = "0.1.4"
+ [dependencies.cargo-options]
+ version = "0.6.0"
+
+-[dependencies.cargo-xwin]
+-version = "0.14.3"
+-optional = true
+-default-features = false
+-
+-[dependencies.cargo-zigbuild]
+-version = "0.16.10"
+-optional = true
+-default-features = false
+-
+ [dependencies.cargo_metadata]
+ version = "0.15.3"
+
+@@ -310,8 +300,6 @@ version = "4.3.0"
+ [features]
+ cli-completion = ["dep:clap_complete_command"]
+ cross-compile = [
+- "zig",
+- "xwin",
+ ]
+ default = [
+ "full",
+@@ -330,7 +318,6 @@ log = ["tracing-subscriber"]
+ native-tls = [
+ "dep:native-tls",
+ "ureq?/native-tls",
+- "cargo-xwin?/native-tls",
+ "dep:rustls-pemfile",
+ ]
+ password-storage = [
+@@ -340,7 +327,6 @@ password-storage = [
+ rustls = [
+ "dep:rustls",
+ "ureq?/tls",
+- "cargo-xwin?/rustls-tls",
+ "dep:rustls-pemfile",
+ ]
+ scaffolding = [
+@@ -358,5 +344,3 @@ upload = [
+ "wild",
+ "dep:dirs",
+ ]
+-xwin = ["cargo-xwin"]
+-zig = ["cargo-zigbuild"]