summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/mia-vtk9.patch
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2022-07-05 19:39:48 +0000
committerChristopher Baines <mail@cbaines.net>2022-07-07 22:16:11 +0100
commitca291e4f73adafd8113e478705051d1737d81e54 (patch)
tree4d1e84ccfb95f379ca86e33f32535b54c8ee288a /gnu/packages/patches/mia-vtk9.patch
parent6cc559b47dc29d54bab2a3afc9049673cdaeeced (diff)
gnu: mia: Build against VTK 9.
* gnu/packages/image-processing.scm (mia): Build against VTK 9. [inputs]: Remove vtk-7; add vtk. [source]: Add mia-vtk9.patch. * gnu/packages/patches/mia-vtk9.patch: New file. * gnu/local.mk: Add it. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/patches/mia-vtk9.patch')
-rw-r--r--gnu/packages/patches/mia-vtk9.patch64
1 files changed, 64 insertions, 0 deletions
diff --git a/gnu/packages/patches/mia-vtk9.patch b/gnu/packages/patches/mia-vtk9.patch
new file mode 100644
index 0000000000..a8f1adab6c
--- /dev/null
+++ b/gnu/packages/patches/mia-vtk9.patch
@@ -0,0 +1,64 @@
+This patch has been taken from
+https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1012689
+--- a/addons/vtk/CMakeLists.txt
++++ b/addons/vtk/CMakeLists.txt
+@@ -20,9 +20,9 @@
+
+ IF(WITH_VTKIO)
+ if (STRICT_DEPENDECIES)
+- FIND_PACKAGE(VTK REQUIRED COMPONENTS vtkIOImage vtkIOXML vtkIOLegacy)
++ FIND_PACKAGE(VTK REQUIRED COMPONENTS IOImage IOXML IOLegacy)
+ else (STRICT_DEPENDECIES)
+- FIND_PACKAGE(VTK COMPONENTS vtkIOImage vtkIOXML vtkIOLegacy)
++ FIND_PACKAGE(VTK COMPONENTS IOImage IOXML IOLegacy)
+ endif (STRICT_DEPENDECIES)
+ IF(VTK_FOUND)
+ DEFINE_PROPERTY(GLOBAL PROPERTY HAVE_VTK_PROP BRIEF_DOCS "yeah" FULL_DOCS "yeah")
+@@ -41,8 +41,17 @@
+ SET(VTK_LINK_LIBS_3D ${SELECTED_VTK_LIBS} mia3d)
+
+ PLUGIN_WITH_TEST_AND_PREFIX2("mesh" "io" vtkmesh "${VTK_LINK_LIBS_MESH}")
++ target_link_libraries(mesh-io-vtkmesh ${VTK_LIBRARIES})
++ target_link_libraries(mesh-io-vtkmesh-common ${VTK_LIBRARIES})
++ target_link_libraries(test-mesh-io-vtkmesh ${VTK_LIBRARIES})
+ PLUGIN_WITH_TEST_AND_PREFIX2("3dvf" "io" vtkvf "${VTK_LINK_LIBS_3D}")
++ target_link_libraries(3dvf-io-vtkvf ${VTK_LIBRARIES})
++ target_link_libraries(3dvf-io-vtkvf-common ${VTK_LIBRARIES})
++ target_link_libraries(test-3dvf-io-vtkvf ${VTK_LIBRARIES})
+ PLUGIN_WITH_TEST_AND_PREFIX2("3dimage" "io" vtkimage "${VTK_LINK_LIBS_3D}")
++ target_link_libraries(3dimage-io-vtkimage ${VTK_LIBRARIES})
++ target_link_libraries(3dimage-io-vtkimage-common ${VTK_LIBRARIES})
++ target_link_libraries(test-3dimage-io-vtkimage ${VTK_LIBRARIES})
+
+ ELSEIF(VTK_FOUND)
+ MESSAGE(MESSAGE "VTK not found, disabled")
+--- a/addons/vtk/vtkmesh.cc
++++ b/addons/vtk/vtkmesh.cc
+@@ -78,7 +78,8 @@
+ // read all cells, if a cell is formed of more than 3 corners, then triangulate,
+ // if it hes less then 3 corners, ignore it (no wireframes supported here
+ auto triangles = CVtkMeshIO::PTrianglefield(new CVtkMeshIO::CTrianglefield ());
+- vtkIdType npts, *pts;
++ vtkIdType npts;
++ vtkIdType const *pts;
+ auto strips = mesh.GetStrips();
+
+ while (strips->GetNextCell(npts, pts)) {
+@@ -183,7 +184,7 @@
+ auto is = mesh.normals_begin();
+
+ for (auto i = 0; i < n_normals; ++i, ++is) {
+- normals->GetTupleValue(i, &is->x);
++ normals->GetTypedTuple(i, &is->x);
+ cvdebug() << i << ": read normal " << *is << "\n";
+ }
+ }
+@@ -217,7 +218,7 @@
+ auto is = mesh.color_begin();
+
+ for (auto i = 0; i < n_colors; ++i, ++is)
+- colors->GetTupleValue(i, &is->x);
++ colors->GetTypedTuple(i, &is->x);
+ }
+
+ PTriangleMesh CVtkMeshIO::do_load(string const& filename) const