summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/mupdf-CVE-2016-9017.patch
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-11-07 22:56:53 -0500
committerLeo Famulari <leo@famulari.name>2016-11-08 11:03:14 -0500
commit667e777b4e4b7303b6f30a001fe2539b7207b65b (patch)
treedbe21fc67ed8aca23b6d2bdafe468f99ef5ed326 /gnu/packages/patches/mupdf-CVE-2016-9017.patch
parent81bf2ccbc408fc2e959d3f5ab019938dad2ce616 (diff)
gnu: mupdf: Fix CVE-2016-{7504,7505,7506,7563,7564,9017,9136} in bundled mujs.
* gnu/packages/patches/mupdf-CVE-2016-7504.patch, gnu/packages/patches/mupdf-CVE-2016-7505.patch gnu/packages/patches/mupdf-CVE-2016-7506.patch gnu/packages/patches/mupdf-CVE-2016-7563.patch gnu/packages/patches/mupdf-CVE-2016-7564.patch gnu/packages/patches/mupdf-CVE-2016-9017.patch gnu/packages/patches/mupdf-CVE-2016-9136.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/pdf.scm (mupdf)[source]: Use them.
Diffstat (limited to 'gnu/packages/patches/mupdf-CVE-2016-9017.patch')
-rw-r--r--gnu/packages/patches/mupdf-CVE-2016-9017.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/patches/mupdf-CVE-2016-9017.patch b/gnu/packages/patches/mupdf-CVE-2016-9017.patch
new file mode 100644
index 0000000000..1e2b7c3258
--- /dev/null
+++ b/gnu/packages/patches/mupdf-CVE-2016-9017.patch
@@ -0,0 +1,46 @@
+Fix CVE-2016-9017:
+
+https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-9107
+http://bugs.ghostscript.com/show_bug.cgi?id=697171
+
+Patch copied from upstream source repository:
+http://git.ghostscript.com/?p=mujs.git;a=commitdiff;h=a5c747f1d40e8d6659a37a8d25f13fb5acf8e767
+
+From a5c747f1d40e8d6659a37a8d25f13fb5acf8e767 Mon Sep 17 00:00:00 2001
+From: Tor Andersson <tor.andersson@artifex.com>
+Date: Tue, 25 Oct 2016 14:08:27 +0200
+Subject: [PATCH] Fix 697171: missed an operand in the bytecode debugger dump.
+
+---
+ jscompile.h | 2 +-
+ jsdump.c | 1 +
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/jscompile.h b/jscompile.h
+index 802cc9e..3054d13 100644
+--- a/thirdparty/mujs/jscompile.h
++++ b/thirdparty/mujs/jscompile.h
+@@ -21,7 +21,7 @@ enum js_OpCode
+
+ OP_NEWARRAY,
+ OP_NEWOBJECT,
+- OP_NEWREGEXP,
++ OP_NEWREGEXP, /* -S,opts- <regexp> */
+
+ OP_UNDEF,
+ OP_NULL,
+diff --git a/jsdump.c b/jsdump.c
+index 1c51c29..37ad88c 100644
+--- a/thirdparty/mujs/jsdump.c
++++ b/thirdparty/mujs/jsdump.c
+@@ -750,6 +750,7 @@ void jsC_dumpfunction(js_State *J, js_Function *F)
+ case OP_INITVAR:
+ case OP_DEFVAR:
+ case OP_GETVAR:
++ case OP_HASVAR:
+ case OP_SETVAR:
+ case OP_DELVAR:
+ case OP_GETPROP_S:
+--
+2.10.2
+