summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ninja-tests.patch
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-01-15 11:02:43 +0800
committer宋文武 <iyzsong@gmail.com>2015-01-15 11:05:18 +0800
commit2b2f91ad87f170e3faf340da48204d50932b2ecd (patch)
treeb2068ecf9218d6b3aad0ea33b57581aaea37c72f /gnu/packages/patches/ninja-tests.patch
parentf220a8384890b2a50f30c62fba56e507333f1a92 (diff)
gnu: ninja: Disable testcase SubprocessTest.InterruptChild.
* gnu/packages/patches/ninja-tests.patch: New file. * gnu/packages/ninja.scm (ninja): Add the patch. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches/ninja-tests.patch')
-rw-r--r--gnu/packages/patches/ninja-tests.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/patches/ninja-tests.patch b/gnu/packages/patches/ninja-tests.patch
new file mode 100644
index 0000000000..3436b6314d
--- /dev/null
+++ b/gnu/packages/patches/ninja-tests.patch
@@ -0,0 +1,44 @@
+SubprocessTest.SetWithLots fails with:
+ Raise [ulimit -n] well above 1025 to make this test go.
+Skip it.
+
+SubprocessTest.InterruptChild fails when using 'system*':
+ *** Failure in src/subprocess_test.cc:83
+ ExitInterrupted == subproc->Finish()
+I can pass it by using 'system' instead of 'system*' when building locally,
+but it still failed on Hydra. Skip it.
+
+--- ninja-1.5.3.orig/src/subprocess_test.cc 2015-01-15 10:34:28.859522176 +0800
++++ ninja-1.5.3/src/subprocess_test.cc 2015-01-15 10:37:52.969572075 +0800
+@@ -72,6 +72,7 @@
+
+ #ifndef _WIN32
+
++#if 0
+ TEST_F(SubprocessTest, InterruptChild) {
+ Subprocess* subproc = subprocs_.Add("kill -INT $$");
+ ASSERT_NE((Subprocess *) 0, subproc);
+@@ -82,6 +83,7 @@
+
+ EXPECT_EQ(ExitInterrupted, subproc->Finish());
+ }
++#endif
+
+ TEST_F(SubprocessTest, InterruptParent) {
+ Subprocess* subproc = subprocs_.Add("kill -INT $PPID ; sleep 1");
+@@ -169,6 +171,7 @@
+ // OS X's process limit is less than 1025 by default
+ // (|sysctl kern.maxprocperuid| is 709 on 10.7 and 10.8 and less prior to that).
+ #if !defined(__APPLE__) && !defined(_WIN32)
++#if 0
+ TEST_F(SubprocessTest, SetWithLots) {
+ // Arbitrary big number; needs to be over 1024 to confirm we're no longer
+ // hostage to pselect.
+@@ -196,6 +199,7 @@
+ }
+ ASSERT_EQ(kNumProcs, subprocs_.finished_.size());
+ }
++#endif
+ #endif // !__APPLE__ && !_WIN32
+
+ // TODO: this test could work on Windows, just not sure how to simply