summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/pokerth-boost.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-12 11:08:42 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-12 11:18:13 -0400
commitf0c8abe85787a0018c0adeb0bc4a6672d46686e4 (patch)
tree5a396beb0a0ba32c63c8e9fa55f01cf41bff8179 /gnu/packages/patches/pokerth-boost.patch
parent07fdfb9e1eb966a83ed99559416be7c72a64a4a2 (diff)
gnu: pokerth: Fix build and modernize package.
Fixes <https://issues.guix.gnu.org/51093>. * gnu/packages/games.scm (pokerth) [source]: Apply patch [inputs]: Use new style. [phases]: Delete trailing #t. Use gexps. {fix-paths}: Remove the gsasl and libircclient related substitutions.
Diffstat (limited to 'gnu/packages/patches/pokerth-boost.patch')
-rw-r--r--gnu/packages/patches/pokerth-boost.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/patches/pokerth-boost.patch b/gnu/packages/patches/pokerth-boost.patch
new file mode 100644
index 0000000000..85d32df299
--- /dev/null
+++ b/gnu/packages/patches/pokerth-boost.patch
@@ -0,0 +1,38 @@
+Retrieved from https://patch-diff.githubusercontent.com/raw/pokerth/pokerth/pull/396.patch
+
+From a769887330a317d55e7f64c71a32ad130ffb9307 Mon Sep 17 00:00:00 2001
+From: Stefan Strogin <steils@gentoo.org>
+Date: Mon, 18 May 2020 03:30:53 +0300
+Subject: [PATCH] Fix using boost placeholders (#395)
+
+---
+ src/net/common/serveracceptwebhelper.cpp | 9 +++++----
+ 1 file changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/src/net/common/serveracceptwebhelper.cpp b/src/net/common/serveracceptwebhelper.cpp
+index f61d4d779..8701e1e99 100644
+--- a/src/net/common/serveracceptwebhelper.cpp
++++ b/src/net/common/serveracceptwebhelper.cpp
+@@ -29,6 +29,7 @@
+ * as that of the covered work. *
+ *****************************************************************************/
+
++#include <boost/bind/bind.hpp>
+ #include <net/serveracceptwebhelper.h>
+ #include <net/sessiondata.h>
+ #include <net/webreceivebuffer.h>
+@@ -58,10 +59,10 @@ ServerAcceptWebHelper::Listen(unsigned serverPort, bool /*ipv6*/, const std::str
+
+ m_webSocketServer->init_asio(m_ioService.get());
+
+- m_webSocketServer->set_validate_handler(boost::bind(boost::mem_fn(&ServerAcceptWebHelper::validate), this, _1));
+- m_webSocketServer->set_open_handler(boost::bind(boost::mem_fn(&ServerAcceptWebHelper::on_open), this, _1));
+- m_webSocketServer->set_close_handler(boost::bind(boost::mem_fn(&ServerAcceptWebHelper::on_close), this, _1));
+- m_webSocketServer->set_message_handler(boost::bind(boost::mem_fn(&ServerAcceptWebHelper::on_message), this, _1, _2));
++ m_webSocketServer->set_validate_handler(boost::bind(boost::mem_fn(&ServerAcceptWebHelper::validate), this, boost::placeholders::_1));
++ m_webSocketServer->set_open_handler(boost::bind(boost::mem_fn(&ServerAcceptWebHelper::on_open), this, boost::placeholders::_1));
++ m_webSocketServer->set_close_handler(boost::bind(boost::mem_fn(&ServerAcceptWebHelper::on_close), this, boost::placeholders::_1));
++ m_webSocketServer->set_message_handler(boost::bind(boost::mem_fn(&ServerAcceptWebHelper::on_message), this, boost::placeholders::_1, boost::placeholders::_2));
+
+ m_webSocketServer->listen(serverPort);
+ m_webSocketServer->start_accept();