summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-disable-ssl-test.patch
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2016-06-20 14:05:20 -0500
committerLeo Famulari <leo@famulari.name>2016-08-29 21:44:11 -0400
commitd0b73960db051baa468fc1a0fbab21fa9f89f885 (patch)
treed01ed5fa7c29ac9e4d5191ca6ef76f393a9da29f /gnu/packages/patches/python-disable-ssl-test.patch
parent568230c3787002af8c174838c334e39f0128a2bb (diff)
gnu: python-3.4: Update to 3.4.5.
* gnu/packages/patches/python-disable-ssl-test.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/python.scm (python-3.4): Update to 3.4.5. [source]: Remove patch. [arguments]: Remove field. (python-minimal)[inputs]: Add libffi.
Diffstat (limited to 'gnu/packages/patches/python-disable-ssl-test.patch')
-rw-r--r--gnu/packages/patches/python-disable-ssl-test.patch12
1 files changed, 0 insertions, 12 deletions
diff --git a/gnu/packages/patches/python-disable-ssl-test.patch b/gnu/packages/patches/python-disable-ssl-test.patch
deleted file mode 100644
index e351c77505..0000000000
--- a/gnu/packages/patches/python-disable-ssl-test.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Disable a test that fails with openssl-1.0.2b.
-
---- Lib/test/test_ssl.py.orig 2015-02-25 06:27:45.000000000 -0500
-+++ Lib/test/test_ssl.py 2015-06-12 03:14:09.395212502 -0400
-@@ -2718,6 +2718,7 @@
- chatty=True, connectionchatty=True)
- self.assertIs(stats['compression'], None)
-
-+ @unittest.skipIf(True, "openssl 1.0.2b complains: dh key too small")
- def test_dh_params(self):
- # Check we can get a connection with ephemeral Diffie-Hellman
- context = ssl.SSLContext(ssl.PROTOCOL_TLSv1)