summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-docrepr-fix-tests.patch
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2023-05-22 20:17:39 +0000
committerLudovic Courtès <ludo@gnu.org>2023-06-02 16:08:28 +0200
commit53c47c4f285bf79d62fcf069b53fb34209e014e5 (patch)
treeca2da1fbdb094fd5f6354a694439f0777e4100c7 /gnu/packages/patches/python-docrepr-fix-tests.patch
parentc3f94451445558c4c2302213361430b96b6c6157 (diff)
gnu: python-docrepr: Fix tests.
* gnu/packages/patches/python-docrepr-fix-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it here. * gnu/packages/documentation.scm (python-docrepr)[source]<patches>: Use it here. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/python-docrepr-fix-tests.patch')
-rw-r--r--gnu/packages/patches/python-docrepr-fix-tests.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-docrepr-fix-tests.patch b/gnu/packages/patches/python-docrepr-fix-tests.patch
new file mode 100644
index 0000000000..a209921025
--- /dev/null
+++ b/gnu/packages/patches/python-docrepr-fix-tests.patch
@@ -0,0 +1,16 @@
+Fixes the errors with use of asyncio in docrepr/tests/test_output.py:
+
+> await compare_screenshots(test_id, url)
+E TypeError: 'coroutine' object is not callable
+
+--- a/conftest.py
++++ b/conftest.py
+@@ -65,7 +65,7 @@ def _open_browser(url):
+
+
+ @pytest.fixture
+-async def compare_screenshots(request):
++def compare_screenshots(request):
+ """Run visual regression test on the output."""
+ async def _compare_screenshots(test_id, url):
+ if (request.config.getoption(COMPARE_SCREENSHOTS_OPTION) or