summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-genshi-isstring-helper.patch
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-09-13 13:32:39 -0400
committerLeo Famulari <leo@famulari.name>2018-09-13 13:32:39 -0400
commitd7639407110a584c18bb362c942eeb0933188c66 (patch)
tree8068d0737e2a65f8f9f7080b7f9fb36a74e58e2c /gnu/packages/patches/python-genshi-isstring-helper.patch
parent36e8185667c41740786d9b2eb3672a0f8b902ed8 (diff)
parent7d1cc612938565d935c53bd7a429f41d1f048dae (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches/python-genshi-isstring-helper.patch')
-rw-r--r--gnu/packages/patches/python-genshi-isstring-helper.patch37
1 files changed, 0 insertions, 37 deletions
diff --git a/gnu/packages/patches/python-genshi-isstring-helper.patch b/gnu/packages/patches/python-genshi-isstring-helper.patch
deleted file mode 100644
index 4f6c19bba9..0000000000
--- a/gnu/packages/patches/python-genshi-isstring-helper.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From cc5e07284f44cdd9beec178c69070a53f55d1323 Mon Sep 17 00:00:00 2001
-From: Simon Cross <hodgestar@gmail.com>
-Date: Sun, 16 Feb 2014 18:43:20 +0000
-Subject: [PATCH 03/15] Add isstring helper.
-
----
- genshi/compat.py | 10 +++++++++-
- 1 file changed, 9 insertions(+), 1 deletion(-)
-
-diff --git a/genshi/compat.py b/genshi/compat.py
-index 9787325..6574e39 100644
---- a/genshi/compat.py
-+++ b/genshi/compat.py
-@@ -35,6 +35,15 @@ else:
- 'Python 2 compatibility function. Not usable in Python 3.')
-
-
-+# We need to test if an object is an instance of a string type in places
-+
-+if IS_PYTHON2:
-+ def isstring(obj):
-+ return isinstance(obj, basestring)
-+else:
-+ def isstring(obj):
-+ return isinstance(obj, str)
-+
- # We need to differentiate between StringIO and BytesIO in places
-
- if IS_PYTHON2:
-@@ -112,4 +121,3 @@ except NameError:
- if not x:
- return False
- return True
--
---
-2.12.0
-