summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-typeguard-python3.10.patch
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-03-18 10:17:57 +0100
committerLars-Dominik Braun <lars@6xq.net>2023-03-18 10:41:35 +0100
commita7c96167ae8748a8b76fabaf74a997094cdf7fc5 (patch)
treeee280dc5d37be7cd50f44d7c92f516d7496374a6 /gnu/packages/patches/python-typeguard-python3.10.patch
parent483124bc484d65b4036c098a700681656e6b69fb (diff)
gnu: python-typeguard: Python 3.10 compatibility.
* gnu/packages/patches/python-typeguard-python3.10.patch: New file. * gnu/local.mk: Register it. * gnu/packages/python-xyz.scm (python-typeguard): Use it.
Diffstat (limited to 'gnu/packages/patches/python-typeguard-python3.10.patch')
-rw-r--r--gnu/packages/patches/python-typeguard-python3.10.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-typeguard-python3.10.patch b/gnu/packages/patches/python-typeguard-python3.10.patch
new file mode 100644
index 0000000000..29321d8918
--- /dev/null
+++ b/gnu/packages/patches/python-typeguard-python3.10.patch
@@ -0,0 +1,47 @@
+Taken from Gentoo, which adapted
+https://github.com/agronholm/typeguard/commit/e0db07a777d5a481eaba6162354adf32286ce21b
+
+diff --git a/src/typeguard/__init__.py b/src/typeguard/__init__.py
+index 5684d63..27fa30b 100644
+--- a/src/typeguard/__init__.py
++++ b/src/typeguard/__init__.py
+@@ -61,22 +61,25 @@ except ImportError:
+ from typing import _ForwardRef as ForwardRef
+ evaluate_forwardref = ForwardRef._eval_type
+
+-if sys.version_info >= (3, 10):
+- from typing import is_typeddict
+-else:
+- _typed_dict_meta_types = ()
+- if sys.version_info >= (3, 8):
+- from typing import _TypedDictMeta
+- _typed_dict_meta_types += (_TypedDictMeta,)
++try:
++ from typing_extensions import is_typeddict
++except ImportError:
++ if sys.version_info >= (3, 10):
++ from typing import is_typeddict
++ else:
++ _typed_dict_meta_types = ()
++ if sys.version_info >= (3, 8):
++ from typing import _TypedDictMeta
++ _typed_dict_meta_types += (_TypedDictMeta,)
+
+- try:
+- from typing_extensions import _TypedDictMeta
+- _typed_dict_meta_types += (_TypedDictMeta,)
+- except ImportError:
+- pass
++ try:
++ from typing_extensions import _TypedDictMeta
++ _typed_dict_meta_types += (_TypedDictMeta,)
++ except ImportError:
++ pass
+
+- def is_typeddict(tp) -> bool:
+- return isinstance(tp, _typed_dict_meta_types)
++ def is_typeddict(tp) -> bool:
++ return isinstance(tp, _typed_dict_meta_types)
+
+
+ if TYPE_CHECKING: