summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python2-subprocess32-disable-input-test.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-06-08 14:46:24 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-08 14:46:24 +0200
commit8c3e9da13a3c92a7db308db8c0d81cb474ad7799 (patch)
tree88d06952aa5cc3a9c4991d9c43eb7950ff174fe1 /gnu/packages/patches/python2-subprocess32-disable-input-test.patch
parent5439c04ebdb7b6405f5ea2446b375f1d155a8d95 (diff)
parent0c5299200ffcd16370f047b7ccb187c60f30da34 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches/python2-subprocess32-disable-input-test.patch')
-rw-r--r--gnu/packages/patches/python2-subprocess32-disable-input-test.patch18
1 files changed, 0 insertions, 18 deletions
diff --git a/gnu/packages/patches/python2-subprocess32-disable-input-test.patch b/gnu/packages/patches/python2-subprocess32-disable-input-test.patch
deleted file mode 100644
index 05b4eef1ba..0000000000
--- a/gnu/packages/patches/python2-subprocess32-disable-input-test.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-This test tries to send a KeyboardInterrupt, which does
-not work in the build environment.
-
---- a/test_subprocess32.py 2017-03-06 22:21:49.334045485 +0100
-+++ b/test_subprocess32.py 2017-03-06 22:22:02.490439949 +0100
-@@ -1299,12 +1299,6 @@
- getattr(p, method)(*args)
- return p
-
-- def test_send_signal(self):
-- p = self._kill_process('send_signal', signal.SIGINT)
-- _, stderr = p.communicate()
-- self.assertIn('KeyboardInterrupt', stderr)
-- self.assertNotEqual(p.wait(), 0)
--
- def test_kill(self):
- p = self._kill_process('kill')
- _, stderr = p.communicate()