summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/qemu-CVE-2015-5154-pt2.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-27 18:23:49 -0400
committerMark H Weaver <mhw@netris.org>2015-07-27 18:50:35 -0400
commit7ef4119f0a4dcf32668f4f7f1ef730d35890a247 (patch)
tree6fb24112f7806bfce8626b67f8fd2679f9a97acc /gnu/packages/patches/qemu-CVE-2015-5154-pt2.patch
parentbae877624e2dfa49d7326929167834236e35a74d (diff)
gnu: qemu: Add fixes for CVE-2015-5154 and CVE-2015-5158.
* gnu/packages/patches/qemu-CVE-2015-5154-pt1.patch, gnu/packages/patches/qemu-CVE-2015-5154-pt2.patch, gnu/packages/patches/qemu-CVE-2015-5154-pt3.patch, gnu/packages/patches/qemu-CVE-2015-5158.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/qemu.scm (qemu-headless)[source]: Add patches.
Diffstat (limited to 'gnu/packages/patches/qemu-CVE-2015-5154-pt2.patch')
-rw-r--r--gnu/packages/patches/qemu-CVE-2015-5154-pt2.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/patches/qemu-CVE-2015-5154-pt2.patch b/gnu/packages/patches/qemu-CVE-2015-5154-pt2.patch
new file mode 100644
index 0000000000..f860cfa3db
--- /dev/null
+++ b/gnu/packages/patches/qemu-CVE-2015-5154-pt2.patch
@@ -0,0 +1,28 @@
+From aa851d30acfbb9580098ac1dc82885530cb8b3c1 Mon Sep 17 00:00:00 2001
+From: Kevin Wolf <kwolf@redhat.com>
+Date: Wed, 3 Jun 2015 14:17:46 +0200
+Subject: [PATCH 2/3] ide/atapi: Fix START STOP UNIT command completion
+
+The command must be completed on all code paths. START STOP UNIT with
+pwrcnd set should succeed without doing anything.
+
+Signed-off-by: Kevin Wolf <kwolf@redhat.com>
+---
+ hw/ide/atapi.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/hw/ide/atapi.c b/hw/ide/atapi.c
+index 950e311..79dd167 100644
+--- a/hw/ide/atapi.c
++++ b/hw/ide/atapi.c
+@@ -983,6 +983,7 @@ static void cmd_start_stop_unit(IDEState *s, uint8_t* buf)
+
+ if (pwrcnd) {
+ /* eject/load only happens for power condition == 0 */
++ ide_atapi_cmd_ok(s);
+ return;
+ }
+
+--
+1.8.3.1
+