summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/quassel-fix-tls-check.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-04-30 04:03:54 -0400
committerMark H Weaver <mhw@netris.org>2018-04-30 04:03:54 -0400
commit3d5ad159b336a9903b31d0be7ae052dbc8d5bfcc (patch)
treeee7dce4e436490a1db5f18e4bfad55511d2fff32 /gnu/packages/patches/quassel-fix-tls-check.patch
parentc77835db04ee20c0afe20600dc8f91a67bc2421e (diff)
parent8c21c64e59d3f4d223d8aeef91f06fdde7de1ab7 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches/quassel-fix-tls-check.patch')
-rw-r--r--gnu/packages/patches/quassel-fix-tls-check.patch25
1 files changed, 0 insertions, 25 deletions
diff --git a/gnu/packages/patches/quassel-fix-tls-check.patch b/gnu/packages/patches/quassel-fix-tls-check.patch
deleted file mode 100644
index 057bc02a14..0000000000
--- a/gnu/packages/patches/quassel-fix-tls-check.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-This allows quasselclient to connect to SSL-enabled quasselcore instances.
-
-The check in qglobal.h requires -fPIC (not -fPIE as it is now). When this check
-fails SSL / TLS is disabled.
-
-This patch comes from the upstream source repository [0] and can be
-removed when the next version is packaged.
-
-[0] https://github.com/quassel/quassel/commit/4768c9e99f99b581d4e32e797db91d0182391696
-
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -428,6 +428,11 @@ endif()
- cmake_push_check_state(RESET)
- set(CMAKE_REQUIRED_INCLUDES ${QT_INCLUDES} ${Qt5Core_INCLUDE_DIRS})
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Core_EXECUTABLE_COMPILE_FLAGS}")
-+
-+if (USE_QT5 AND Qt5_POSITION_INDEPENDENT_CODE)
-+ set(CMAKE_REQUIRED_FLAGS "-fPIC -DQT_NO_VERSION_TAGGING")
-+endif()
-+
- check_cxx_source_compiles("
- #include \"qglobal.h\"
- #if defined QT_NO_SSL
-