summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/rocm-opencl-runtime-4.3-noclinfo.patch
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2022-06-13 11:36:23 -0400
committerLudovic Courtès <ludo@gnu.org>2022-06-16 12:50:06 +0200
commit67c30ff8ad2c729417c9ae24320552e163816a69 (patch)
tree80dc292c0b48af654d589158031f626bec86fcf5 /gnu/packages/patches/rocm-opencl-runtime-4.3-noclinfo.patch
parent25809f5a40c1ef507a4af230c932d15ca4778859 (diff)
gnu: rocm: Update to 5.1.3.
All packages updated at the same time as they have a shared version. rocclr is no longer a stand-alone package, so the previous version is kept as rocclr-4 and the current version is just the source, rocclr-src, needed by rocm-opencl-runtime. * gnu/packages/patches/rocm-opencl-runtime-3.10.0-includes.patch, gnu/packages/patches/rocm-opencl-runtime-4.3-nocltrace.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them. * gnu/packages/patches/rocm-comgr-3.1.0-dependencies.patch, gnu/packages/patches/rocm-opencl-runtime-4.3-noclinfo.patch, gnu/packages/patches/rocm-opencl-runtime-4.3-noopencl.patch: Update patches. * gnu/packages/rocm.scm (rocm-cmake, rocm-device-libs, rocm-comgr, roct-thunk-interface, rocr-runtime, rocm-opencl-runtime, rocminfo, rocm-bandwidth-test): Update to 5.1.3. (roct-thunk-interface)[inputs]: Add libdrm. [native-inputs]: Add gcc:lib and pkg-config. (rocclr-src): New variable. (rocclr-4): New variable (previous version of the package). (rocm-opencl-runtime)[source]: Remove obsolete patches. [arguments]: Rewrite with gexps. Add needed #:configure-flags. [inputs]: Remove rocclr, add numactl. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/rocm-opencl-runtime-4.3-noclinfo.patch')
-rw-r--r--gnu/packages/patches/rocm-opencl-runtime-4.3-noclinfo.patch29
1 files changed, 15 insertions, 14 deletions
diff --git a/gnu/packages/patches/rocm-opencl-runtime-4.3-noclinfo.patch b/gnu/packages/patches/rocm-opencl-runtime-4.3-noclinfo.patch
index 5709e0d19a..97376fd421 100644
--- a/gnu/packages/patches/rocm-opencl-runtime-4.3-noclinfo.patch
+++ b/gnu/packages/patches/rocm-opencl-runtime-4.3-noclinfo.patch
@@ -4,25 +4,26 @@ diff --git a/CMakeLists.txt.orig b/CMakeLists.txt
index 76847d3..3f62bfe 100644
--- a/CMakeLists.txt.orig
+++ b/CMakeLists.txt
-@@ -72,7 +72,7 @@ find_package(ROCclr REQUIRED CONFIG
+@@ -15,9 +15,9 @@ option(FILE_REORG_BACKWARD_COMPATIBILITY "Enable File Reorganization backward co
- add_subdirectory(khronos/icd)
+
+ set(OPENCL_ICD_LOADER_HEADERS_DIR "${CMAKE_CURRENT_LIST_DIR}/khronos/headers/opencl2.2" CACHE PATH "")
+ #add_subdirectory(khronos/icd)
add_subdirectory(amdocl)
-add_subdirectory(tools/clinfo)
+#add_subdirectory(tools/clinfo)
add_subdirectory(tools/cltrace)
if(BUILD_TESTS)
add_subdirectory(tests/ocltst)
-@@ -108,9 +108,9 @@ endif()
- ###--- Packaging ------------------------------------------------------------###
+diff --git a/packaging/CMakeLists.txt b/packaging/CMakeLists.txt
+index 48353eb..cd1e7c1 100644
+--- a/packaging/CMakeLists.txt
++++ b/packaging/CMakeLists.txt
+@@ -5,6 +5,6 @@ set(CPACK_COMPONENTS_ALL binary dev icd)
+ set(CPACK_DEB_COMPONENT_INSTALL ON)
+ set(CPACK_RPM_COMPONENT_INSTALL ON)
- # MAIN package
--install(PROGRAMS $<TARGET_FILE:clinfo>
-- DESTINATION bin
-- COMPONENT MAIN)
-+#install(PROGRAMS $<TARGET_FILE:clinfo>
-+# DESTINATION bin
-+# COMPONENT MAIN)
- install(PROGRAMS $<TARGET_FILE:cltrace>
- DESTINATION lib
- COMPONENT MAIN)
+-install(TARGETS clinfo DESTINATION bin COMPONENT binary)
++#install(TARGETS clinfo DESTINATION bin COMPONENT binary)
+ install(TARGETS amdocl DESTINATION lib COMPONENT binary)
+ install(FILES ${CMAKE_SOURCE_DIR}/LICENSE.txt DESTINATION share/doc/${CMAKE_PROJECT_NAME} COMPONENT binary)