summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/rust-1.70-fix-rustix-build.patch
diff options
context:
space:
mode:
authorFries <fries1234@protonmail.com>2023-09-18 15:19:49 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-18 11:35:39 +0300
commit299a223835f875c9fcb526a76bbe0b7f32cbefaf (patch)
tree790bbba8347336cadf064f28257ae895fff697af /gnu/packages/patches/rust-1.70-fix-rustix-build.patch
parentfb04d0139e4415e9e6c89c5fb72618b8d80b94bb (diff)
gnu: Add rust-1.70.
* gnu/packages/rust.scm (rust-1.70): New variable. * gnu/packages/patches/rust-1.70-fix-rustix-build.patch: New file. * gnu/local.mk (dist_patch_DATA): Register file. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/patches/rust-1.70-fix-rustix-build.patch')
-rw-r--r--gnu/packages/patches/rust-1.70-fix-rustix-build.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/patches/rust-1.70-fix-rustix-build.patch b/gnu/packages/patches/rust-1.70-fix-rustix-build.patch
new file mode 100644
index 0000000000..d72a8fb07a
--- /dev/null
+++ b/gnu/packages/patches/rust-1.70-fix-rustix-build.patch
@@ -0,0 +1,21 @@
+@@ -0,0 +1,20 @@
+--- a/vendor/fd-lock/Cargo.toml 2023-05-31 14:44:48.000000000 -0700
++++ b/vendor/fd-lock/Cargo.toml 2023-07-14 21:19:34.637702319 -0700
+@@ -45,7 +45,7 @@
+
+ [target."cfg(unix)".dependencies.rustix]
+ version = "0.37.0"
+-features = ["fs"]
++features = ["fs", "cc"]
+
+ [target."cfg(windows)".dependencies.windows-sys]
+ version = "0.45.0"
+--- a/src/bootstrap/Cargo.lock 2023-07-11 20:32:40.000000000 -0700
++++ b/src/bootstrap/Cargo.lock 2023-07-14 22:41:53.269284713 -0700
+@@ -618,6 +618,7 @@
+ dependencies = [
+ "bitflags",
++ "cc",
+ "errno",
+ "io-lifetimes",
+ "libc",