summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/sbcl-geco-fix-organism-class.patch
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-11-29 14:19:55 +0000
committerChristopher Baines <mail@cbaines.net>2020-11-29 17:34:18 +0000
commitff01206345e2306cc633db48e0b29eab9077091a (patch)
tree25c7ee17005dadc9bf4fae3f0873e03a4704f782 /gnu/packages/patches/sbcl-geco-fix-organism-class.patch
parented2545f0fa0e2ad99d5a0c45f532c539b299b9fb (diff)
parent7c2e67400ffaef8eb6f30ef7126c976ee3d7e36c (diff)
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/patches/sbcl-geco-fix-organism-class.patch')
-rw-r--r--gnu/packages/patches/sbcl-geco-fix-organism-class.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/sbcl-geco-fix-organism-class.patch b/gnu/packages/patches/sbcl-geco-fix-organism-class.patch
new file mode 100644
index 0000000000..817596241e
--- /dev/null
+++ b/gnu/packages/patches/sbcl-geco-fix-organism-class.patch
@@ -0,0 +1,13 @@
+Fix the ORGANISM class so that SBCL >= 2.0.9 can compile it without error.
+
+--- a/classes.lisp 2020-10-28 12:11:10.725659464 +0100
++++ b/classes.lisp 2020-10-31 17:34:36.822752447 +0100
+@@ -148,7 +148,7 @@
+ :accessor score
+ :initarg :score
+ :initform 'nil
+- :type number)
++ :type (or number null))
+ (NORMALIZED-SCORE
+ :accessor normalized-score
+ :initarg :normalized-score