summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/scribus-1.5.8-poppler-22.09.0.patch
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-24 21:16:02 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-25 06:17:16 +0200
commit8495069bed0d51a21ff609f7036ff40d73ff07a8 (patch)
treef79ef32faa8b73823c89fab25dcc333628427f17 /gnu/packages/patches/scribus-1.5.8-poppler-22.09.0.patch
parent7fc2c442c85aefe21e61502f50b27651b043b5cd (diff)
gnu: scribus: Fix build with latest poppler.
* gnu/packages/patches/scribus-1.5.8-poppler-22.03.0.patch, gnu/packages/patches/scribus-1.5.8-poppler-22.04.0.patch, gnu/packages/patches/scribus-1.5.8-poppler-22.09.0.patch, gnu/packages/patches/scribus-1.5.8-poppler-22.2.0-1.patch, gnu/packages/patches/scribus-1.5.8-poppler-22.2.0-2.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/scribus.scm (scribus)[source]: Add patches. [arguments]: Enable WANT_CPP17 option.
Diffstat (limited to 'gnu/packages/patches/scribus-1.5.8-poppler-22.09.0.patch')
-rw-r--r--gnu/packages/patches/scribus-1.5.8-poppler-22.09.0.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/patches/scribus-1.5.8-poppler-22.09.0.patch b/gnu/packages/patches/scribus-1.5.8-poppler-22.09.0.patch
new file mode 100644
index 0000000000..106a6f5162
--- /dev/null
+++ b/gnu/packages/patches/scribus-1.5.8-poppler-22.09.0.patch
@@ -0,0 +1,20 @@
+--- a/scribus/plugins/import/pdf/slaoutput.cpp
++++ b/scribus/plugins/import/pdf/slaoutput.cpp
+@@ -3741,9 +3741,16 @@ void SlaOutputDev::getPenState(GfxState *state)
+ break;
+ }
+ double lw = state->getLineWidth();
+- double *dashPattern;
+ int dashLength;
++#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(22, 9, 0)
++ const double *dashPattern;
++ const std::vector<double> &dash = state->getLineDash(&DashOffset);
++ dashPattern = dash.data();
++ dashLength = dash.size();
++#else
++ double *dashPattern;
+ state->getLineDash(&dashPattern, &dashLength, &DashOffset);
++#endif
+ QVector<double> pattern(dashLength);
+ for (int i = 0; i < dashLength; ++i)
+ {