summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/sdl2-mesa-compat.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-05 17:57:35 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-05 17:57:35 +0100
commit9d5aa009062a49bd035ae33e37f6562526e7d38c (patch)
tree4ff2302863a5cf9f3cf604240ea793152156f532 /gnu/packages/patches/sdl2-mesa-compat.patch
parent60bd56c6d8368c23dcd97b26501771c82316fc8c (diff)
parent2c2fc24b899d3286774f60405888718d98211213 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches/sdl2-mesa-compat.patch')
-rw-r--r--gnu/packages/patches/sdl2-mesa-compat.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/patches/sdl2-mesa-compat.patch b/gnu/packages/patches/sdl2-mesa-compat.patch
new file mode 100644
index 0000000000..8182e582e7
--- /dev/null
+++ b/gnu/packages/patches/sdl2-mesa-compat.patch
@@ -0,0 +1,21 @@
+Do not include GLES header when OpenGL headers are already included.
+
+Taken from upstream:
+https://hg.libsdl.org/SDL/rev/369b01006eb2
+
+diff -r 4cbaffd0083b -r 369b01006eb2 src/video/SDL_video.c
+--- a/src/video/SDL_video.c Fri Oct 11 06:18:24 2019 +0200
++++ b/src/video/SDL_video.c Sat Oct 12 18:47:56 2019 +0200
+@@ -37,9 +37,9 @@
+ #include "SDL_opengl.h"
+ #endif /* SDL_VIDEO_OPENGL */
+
+-#if SDL_VIDEO_OPENGL_ES
++#if SDL_VIDEO_OPENGL_ES && !SDL_VIDEO_OPENGL
+ #include "SDL_opengles.h"
+-#endif /* SDL_VIDEO_OPENGL_ES */
++#endif /* SDL_VIDEO_OPENGL_ES && !SDL_VIDEO_OPENGL */
+
+ /* GL and GLES2 headers conflict on Linux 32 bits */
+ #if SDL_VIDEO_OPENGL_ES2 && !SDL_VIDEO_OPENGL
+