summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/serf-comment-style-fix.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-05-07 12:19:33 -0400
committerMark H Weaver <mhw@netris.org>2015-05-07 12:22:09 -0400
commit88b6b125baeb41908a40591d403bceb6a9aafb10 (patch)
tree61024eec12b8c44fda361b88c71c861f819d8541 /gnu/packages/patches/serf-comment-style-fix.patch
parentdc77f0d321be96a8f6817dbd33f5414d333d7fba (diff)
gnu: serf: Apply upstream fixes.
* gnu/packages/patches/serf-comment-style-fix.patch, gnu/packages/patches/serf-deflate-buckets-test-fix.patch: New file. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/web.scm (serf): Add patches. Remove 'remove-non-c89-comment' phase.
Diffstat (limited to 'gnu/packages/patches/serf-comment-style-fix.patch')
-rw-r--r--gnu/packages/patches/serf-comment-style-fix.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/patches/serf-comment-style-fix.patch b/gnu/packages/patches/serf-comment-style-fix.patch
new file mode 100644
index 0000000000..5d336fb3c8
--- /dev/null
+++ b/gnu/packages/patches/serf-comment-style-fix.patch
@@ -0,0 +1,23 @@
+r2443 | andreas.stieger@gmx.de | 2014-10-21 17:42:56 -0400 (Tue, 21 Oct 2014) | 7 lines
+
+Follow-up to r2419: Correct comment style
+
+* test/test_buckets.c
+ (deflate_compress): Correct comment style not supported by strict
+ compilers, fails on /branches/1.3.x
+
+Index: test/test_buckets.c
+===================================================================
+--- test/test_buckets.c (revision 2442)
++++ test/test_buckets.c (revision 2443)
+@@ -1323,9 +1323,9 @@
+
+ /* The largest buffer we should need is 0.1% larger than the
+ uncompressed data, + 12 bytes. This info comes from zlib.h.
++ buf_size = orig_len + (orig_len / 1000) + 12;
+ Note: This isn't sufficient when using Z_NO_FLUSH and extremely compressed
+ data. Use a buffer bigger than what we need. */
+-// buf_size = orig_len + (orig_len / 1000) + 12;
+ buf_size = 100000;
+
+ write_buf = apr_palloc(pool, buf_size);