summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/slim-sigusr1.patch
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-01-01 21:56:00 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-01-01 21:56:00 +0100
commit1cd97066c2dc84c6e538cfa63820e18f6c12a414 (patch)
tree973b920b3f7c551a4baed8ce87147c2591ce3086 /gnu/packages/patches/slim-sigusr1.patch
parentb8175bc85a9709e29b60a0b56bafa56ca790383b (diff)
parentee0cf3b9ff4cd5a9d3637d09677195ea9ee1a8c0 (diff)
Merge branch 'master' into gnome-team
Diffstat (limited to 'gnu/packages/patches/slim-sigusr1.patch')
-rw-r--r--gnu/packages/patches/slim-sigusr1.patch33
1 files changed, 0 insertions, 33 deletions
diff --git a/gnu/packages/patches/slim-sigusr1.patch b/gnu/packages/patches/slim-sigusr1.patch
deleted file mode 100644
index 344b02933e..0000000000
--- a/gnu/packages/patches/slim-sigusr1.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-This patch fixes SLiM so it really waits for the X server to be ready
-before attempting to connect to it. Indeed, the X server notices that
-its parent process has a handler for SIGUSR1, and consequently sends it
-SIGUSR1 when it's ready to accept connections.
-
-The problem was that SLiM doesn't pay attention to SIGUSR1. So in practice,
-if X starts slowly, then SLiM gets ECONNREFUSED a couple of time on
-/tmp/.X11-unix/X0, then goes on trying to connect to localhost:6000,
-where nobody answers; eventually, it times out and tries again on
-/tmp/.X11-unix/X0, and finally it shows up on the screen.
-
-Patch by L. Courtès.
-
---- slim-1.3.6/app.cpp 2014-02-05 15:27:20.000000000 +0100
-+++ slim-1.3.6/app.cpp 2014-02-09 22:42:04.000000000 +0100
-@@ -119,7 +119,9 @@ void CatchSignal(int sig) {
- exit(ERR_EXIT);
- }
-
-+static volatile int got_sigusr1 = 0;
- void User1Signal(int sig) {
-+ got_sigusr1 = 1;
- signal(sig, User1Signal);
- }
-
-@@ -884,6 +886,7 @@ int App::WaitForServer() {
- int ncycles = 120;
- int cycles;
-
-+ while (!got_sigusr1);
- for(cycles = 0; cycles < ncycles; cycles++) {
- if((Dpy = XOpenDisplay(DisplayName))) {
- XSetIOErrorHandler(xioerror);