summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/sunxi-tools-remove-sys-io.patch
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-10-13 23:39:27 +0200
committerMarius Bakke <marius@gnu.org>2020-10-13 23:39:27 +0200
commitf7175626ffce578be1bc6df4916a129f86557872 (patch)
tree2eb0040522f2883764b3e09dc36595d68eeb14c1 /gnu/packages/patches/sunxi-tools-remove-sys-io.patch
parent2b6ecdf41a09ab9ecae06d7c537583a2f0f28efc (diff)
parente8c5533d26b4441c96e9ae92350efcb24d787c4b (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/patches/sunxi-tools-remove-sys-io.patch')
-rw-r--r--gnu/packages/patches/sunxi-tools-remove-sys-io.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/patches/sunxi-tools-remove-sys-io.patch b/gnu/packages/patches/sunxi-tools-remove-sys-io.patch
new file mode 100644
index 0000000000..fc1e5ea28d
--- /dev/null
+++ b/gnu/packages/patches/sunxi-tools-remove-sys-io.patch
@@ -0,0 +1,52 @@
+From 783cbd59fcf086a9aaf603271823fb4ca71f0c55 Mon Sep 17 00:00:00 2001
+From: Danny Milosavljevic <dannym@scratchpost.org>
+Date: Thu, 8 Oct 2020 23:01:05 +0200
+Subject: [PATCH] meminfo: Replace sys/io.h by direct register accesses.
+See: https://github.com/linux-sunxi/sunxi-tools/pull/144
+
+Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
+---
+ meminfo.c | 9 ++++-----
+ 1 file changed, 4 insertions(+), 5 deletions(-)
+
+diff --git a/meminfo.c b/meminfo.c
+index 0b0ff23..3b3a5df 100644
+--- a/meminfo.c
++++ b/meminfo.c
+@@ -22,7 +22,6 @@
+ #include <sys/mman.h>
+ #include <stdint.h>
+ #include <errno.h>
+-#include <sys/io.h>
+ #include <stdbool.h>
+
+ #include "common.h"
+@@ -74,24 +73,24 @@ static enum sunxi_soc_version soc_version;
+ unsigned int
+ sunxi_io_read(void *base, int offset)
+ {
+- return inl((unsigned long) (base + offset));
++ return *(volatile unsigned int*) (base + offset);
+ }
+
+ void
+ sunxi_io_write(void *base, int offset, unsigned int value)
+ {
+- outl(value, (unsigned long) (base + offset));
++ *(volatile unsigned int*) (base + offset) = value;
+ }
+
+ void
+ sunxi_io_mask(void *base, int offset, unsigned int value, unsigned int mask)
+ {
+- unsigned int tmp = inl((unsigned long) (base + offset));
++ unsigned int tmp = sunxi_io_read(base, offset);
+
+ tmp &= ~mask;
+ tmp |= value & mask;
+
+- outl(tmp, (unsigned long) (base + offset));
++ sunxi_io_write(base, offset, tmp);
+ }
+
+