summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/totem-debug-format-fix.patch
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-05-13 02:03:22 -0400
committerLeo Famulari <leo@famulari.name>2016-05-13 02:08:11 -0400
commiteb74eb4199db3faac654114257996f244ec308f5 (patch)
tree9504ae968710941557be6d1edd244618eeb14448 /gnu/packages/patches/totem-debug-format-fix.patch
parentf10e7ef475da430afa46e0b062010952ed886694 (diff)
parente9017c98d61f305b624bacaa30e8891ec0100980 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches/totem-debug-format-fix.patch')
-rw-r--r--gnu/packages/patches/totem-debug-format-fix.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/patches/totem-debug-format-fix.patch b/gnu/packages/patches/totem-debug-format-fix.patch
new file mode 100644
index 0000000000..7ddd31ee10
--- /dev/null
+++ b/gnu/packages/patches/totem-debug-format-fix.patch
@@ -0,0 +1,11 @@
+--- totem-3.20.1/src/backend/bacon-video-widget.c.orig 2016-03-22 12:45:32.000000000 -0400
++++ totem-3.20.1/src/backend/bacon-video-widget.c 2016-05-11 02:49:55.299109551 -0400
+@@ -2334,7 +2334,7 @@
+ if (!gst_toc_entry_get_start_stop_times (entry, &start, &stop)) {
+ GST_DEBUG ("Chapter #%d (couldn't get times)", i);
+ } else {
+- GST_DEBUG ("Chapter #%d (start: %li stop: %li)", i, start, stop);
++ GST_DEBUG ("Chapter #%d (start: %li stop: %li)", i, (long) start, (long) stop);
+ }
+ }
+