summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/tpetra-remove-duplicate-using.patch
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-10-23 21:09:49 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-10-23 21:09:49 +0200
commite38d6a9c2fba815ac34e74baa843f15e33846813 (patch)
tree0a3dd602449386119fc15de32a5cf7e5f607b2a1 /gnu/packages/patches/tpetra-remove-duplicate-using.patch
parentda716c8b9cdc358609a368bd5da70b31cd97a938 (diff)
parentcbd20d627497053871db863970c07d93c7081786 (diff)
Merge branch 'master' into gnome-team
Change-Id: Ib6f55bebef2fb235fa59fd5442102a3e0ace3191
Diffstat (limited to 'gnu/packages/patches/tpetra-remove-duplicate-using.patch')
-rw-r--r--gnu/packages/patches/tpetra-remove-duplicate-using.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/tpetra-remove-duplicate-using.patch b/gnu/packages/patches/tpetra-remove-duplicate-using.patch
new file mode 100644
index 0000000000..e9cb2c6472
--- /dev/null
+++ b/gnu/packages/patches/tpetra-remove-duplicate-using.patch
@@ -0,0 +1,18 @@
+commit 919ceb0acbf4c6bc4f463433504a338c643612c2
+Author: Karen D. Devine <kddevin@sandia.gov>
+Date: Tue Feb 2 13:49:13 2021 -0700
+
+ tpetra: removed duplicate using statement #8673
+
+diff --git a/packages/tpetra/core/src/Tpetra_Details_FixedHashTable_def.hpp b/packages/tpetra/core/src/Tpetra_Details_FixedHashTable_def.hpp
+index a76f78c41a8..69d4dc46d03 100644
+--- a/packages/tpetra/core/src/Tpetra_Details_FixedHashTable_def.hpp
++++ b/packages/tpetra/core/src/Tpetra_Details_FixedHashTable_def.hpp
+@@ -1094,7 +1094,6 @@ init (const keys_type& keys,
+
+ // Allocate the array of (key,value) pairs. Don't fill it with
+ // zeros, because we will fill it with actual data below.
+- using Kokkos::ViewAllocateWithoutInitializing;
+ typedef typename val_type::non_const_type nonconst_val_type;
+ nonconst_val_type val (ViewAllocateWithoutInitializing ("Tpetra::FixedHashTable::pairs"),
+ theNumKeys);