summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/tpetra-remove-duplicate-using.patch
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2023-10-12 10:02:25 -0400
committerLudovic Courtès <ludo@gnu.org>2023-10-21 00:27:26 +0200
commitfed6ac2ae182597a492b17a29ed8b26986498755 (patch)
tree085d6d159f779bd4d3143add0ad9358512c7adef /gnu/packages/patches/tpetra-remove-duplicate-using.patch
parentc942f4dcaba8f44d9f89540c22825e935c5acfd1 (diff)
gnu: trilinos-for-dealii-openmpi: Fix build.
This fixes the error error: ‘std::hypot’ has not been declared caused by using an older version of gcc, but requires some patches to placate newer versions of gcc. * gnu/packages/maths.scm (trilinos-for-dealii-openmpi)[origin]: Add patches. [native-inputs]: Remove gcc-7. * gnu/packages/patches/teuchos-remove-duplicate-using.patch: New file. * gnu/packages/patches/tpetra-remove-duplicate-using.patch: Likewise. * gnu/local.mk (dist_patch_DATA): Register them. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/tpetra-remove-duplicate-using.patch')
-rw-r--r--gnu/packages/patches/tpetra-remove-duplicate-using.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/tpetra-remove-duplicate-using.patch b/gnu/packages/patches/tpetra-remove-duplicate-using.patch
new file mode 100644
index 0000000000..e9cb2c6472
--- /dev/null
+++ b/gnu/packages/patches/tpetra-remove-duplicate-using.patch
@@ -0,0 +1,18 @@
+commit 919ceb0acbf4c6bc4f463433504a338c643612c2
+Author: Karen D. Devine <kddevin@sandia.gov>
+Date: Tue Feb 2 13:49:13 2021 -0700
+
+ tpetra: removed duplicate using statement #8673
+
+diff --git a/packages/tpetra/core/src/Tpetra_Details_FixedHashTable_def.hpp b/packages/tpetra/core/src/Tpetra_Details_FixedHashTable_def.hpp
+index a76f78c41a8..69d4dc46d03 100644
+--- a/packages/tpetra/core/src/Tpetra_Details_FixedHashTable_def.hpp
++++ b/packages/tpetra/core/src/Tpetra_Details_FixedHashTable_def.hpp
+@@ -1094,7 +1094,6 @@ init (const keys_type& keys,
+
+ // Allocate the array of (key,value) pairs. Don't fill it with
+ // zeros, because we will fill it with actual data below.
+- using Kokkos::ViewAllocateWithoutInitializing;
+ typedef typename val_type::non_const_type nonconst_val_type;
+ nonconst_val_type val (ViewAllocateWithoutInitializing ("Tpetra::FixedHashTable::pairs"),
+ theNumKeys);