summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ucx-tcp-iface-ioctl.patch
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2023-03-27 11:34:50 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-03-27 11:34:50 +0200
commitc10bfa888545fb03d70a46ec70a676c69e6e0587 (patch)
tree84bc2f67911792af3c91f2d054ebfe354453cedb /gnu/packages/patches/ucx-tcp-iface-ioctl.patch
parent0ac126e4f20ad9aafd93717b8cdefb7789085e85 (diff)
gnu: ucx: Update to 1.14.0.
* gnu/packages/fabric-management.scm (ucx): Update to 1.14.0. * gnu/packages/patches/ucx-tcp-iface-ioctl.patch: Adapt patch to new ucx version.
Diffstat (limited to 'gnu/packages/patches/ucx-tcp-iface-ioctl.patch')
-rw-r--r--gnu/packages/patches/ucx-tcp-iface-ioctl.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/patches/ucx-tcp-iface-ioctl.patch b/gnu/packages/patches/ucx-tcp-iface-ioctl.patch
index 56f06fc920..c441a0861a 100644
--- a/gnu/packages/patches/ucx-tcp-iface-ioctl.patch
+++ b/gnu/packages/patches/ucx-tcp-iface-ioctl.patch
@@ -54,7 +54,7 @@ index cad4a2709..7c1d2c9de 100644
+ for (i = 0; i < conf.ifc_len / sizeof(struct ifreq); i++) {
+ const char *name = reqs[i].ifr_name;
+
-+ if (!ucs_netif_is_active(name)) {
++ if (!ucs_netif_is_active(name, AF_INET)) {
+ continue;
+ }
+
@@ -87,9 +87,9 @@ index cad4a2709..7c1d2c9de 100644
unsigned *num_devices_p)
@@ -599,9 +663,9 @@ ucs_status_t uct_tcp_query_devices(uct_md_h md,
- dir = opendir(netdev_dir);
+ dir = opendir(UCT_TCP_IFACE_NETDEV_DIR);
if (dir == NULL) {
-- ucs_error("opendir(%s) failed: %m", netdev_dir);
+- ucs_error("opendir(%s) failed: %m", UCT_TCP_IFACE_NETDEV_DIR);
- status = UCS_ERR_IO_ERROR;
- goto out;
+ /* When /sys is unavailable, as can be the case in a container,