summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ungoogled-chromium-system-jsoncpp.patch
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-07-19 08:59:48 +0200
committerMarius Bakke <marius@gnu.org>2020-07-19 14:23:16 +0200
commitc91c132fc42c6e67140b393b963d7ced009f093e (patch)
tree1cd9a75687f00410588868d395f150ac1e668ff3 /gnu/packages/patches/ungoogled-chromium-system-jsoncpp.patch
parentddedd2727029d0dcabf3f7a0b763f94ace5d5622 (diff)
gnu: ungoogled-chromium: Update to 84.0.4147.89-0.df199c0.
* gnu/packages/patches/ungoogled-chromium-system-jsoncpp.patch, gnu/packages/patches/ungoogled-chromium-system-zlib.patch: Delete files. * gnu/packages/patches/ungoogled-chromium-system-nspr.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/chromium.scm (%preserved-third-party-files): Adjust for 84. (%ungoogled-revision): Set to df199c04ff367da59ce52a23a3f3b305dd3b00c3. (%debian-revision): Set to debian/83.0.4103.116-3. (%gentoo-revision): Set to f3f649046d31ebdbc8c4a302b2384504eff78027. (chromium-gcc-patchset, %chromium-gcc-patches): New variables. (%gentoo-patches): Remove GCC patches, which have been moved to the above repo. Add ffmpeg compatibility patch. (%debian-patches): Add zlib and jsoncpp patch; remove nspr patch. (%ungoogled-origin): Update hash. (ungoogled-chromium-snippet): Add the new GCC patches. Remove obsolete local patches, add new. (xcb-proto/python2): New variable. (ungoogled-chromium): Update to 84.0.4147.89-0..df199c0. [arguments]: Add "is_unsafe_developer_build", "max_jobs_per_link", "exclude_unwind_tables", "xcbproto_path", "perfetto_use_system_protobuf" to #:configure-flags. Remove "linux_use_bundled_binutils". Adjust vulkan header substitutions. [native-inputs]: Remove YASM. [inputs]: Change from FFMPEG-4.2 to FFMPEG. Add PROTOBUF and XCB-PROTO/PYTHON2.
Diffstat (limited to 'gnu/packages/patches/ungoogled-chromium-system-jsoncpp.patch')
-rw-r--r--gnu/packages/patches/ungoogled-chromium-system-jsoncpp.patch65
1 files changed, 0 insertions, 65 deletions
diff --git a/gnu/packages/patches/ungoogled-chromium-system-jsoncpp.patch b/gnu/packages/patches/ungoogled-chromium-system-jsoncpp.patch
deleted file mode 100644
index 294e1ea33b..0000000000
--- a/gnu/packages/patches/ungoogled-chromium-system-jsoncpp.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-Build with the system jsoncpp instead of the bundled one.
-
-Adapted from Debian:
-https://salsa.debian.org/chromium-team/chromium/-/blob/master/debian/patches/system/jsoncpp.patch
-
-diff --git a/third_party/jsoncpp/BUILD.gn b/third_party/jsoncpp/BUILD.gn
---- a/third_party/jsoncpp/BUILD.gn
-+++ b/third_party/jsoncpp/BUILD.gn
-@@ -3,52 +3,14 @@
- # found in the LICENSE file.
-
- import("//testing/libfuzzer/fuzzer_test.gni")
-+import("//build/config/linux/pkg_config.gni")
-
--config("jsoncpp_config") {
-- include_dirs = [
-- "source/include",
-- "generated",
-- ]
--
-- # TODO(crbug.com/983223): Update JsonCpp BUILD.gn to remove deprecated
-- # declaration flag.
-- # This temporary flag allowing clients to update to the new version, and then
-- # update to the new StreamWriter and CharReader classes.
-- if (!is_win || is_clang) {
-- cflags_cc = [ "-Wno-deprecated-declarations" ]
-- }
-+pkg_config("jsoncpp_config") {
-+ packages = [ "jsoncpp" ]
- }
-
--source_set("jsoncpp") {
-- sources = [
-- "generated/version.h",
-- "source/include/json/assertions.h",
-- "source/include/json/autolink.h",
-- "source/include/json/config.h",
-- "source/include/json/features.h",
-- "source/include/json/forwards.h",
-- "source/include/json/json.h",
-- "source/include/json/reader.h",
-- "source/include/json/value.h",
-- "source/include/json/writer.h",
-- "source/src/lib_json/json_reader.cpp",
-- "source/src/lib_json/json_tool.h",
-- "source/src/lib_json/json_value.cpp",
-- "source/src/lib_json/json_writer.cpp",
-- ]
--
-+group("jsoncpp") {
- public_configs = [ ":jsoncpp_config" ]
--
-- defines = [
-- "JSON_USE_EXCEPTION=0",
-- "JSON_USE_NULLREF=0",
-- ]
--
-- include_dirs = [ "source/src/lib_json" ]
--
-- if (!is_win || is_clang) {
-- cflags_cc = [ "-Wno-implicit-fallthrough" ]
-- }
- }
-
- if (build_with_chromium) {