summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/w3m-force-ssl_verify_server-on.patch
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-01-05 19:26:25 -0500
committerLeo Famulari <leo@famulari.name>2016-01-07 02:35:38 -0500
commit62339e2d493bf87a3aabe12e45458581e9705d83 (patch)
tree31a9bd122f8827aa2cf349d87ea040bb5cca5b9e /gnu/packages/patches/w3m-force-ssl_verify_server-on.patch
parente6352001c444a82141ea4457e49e69a1c3f8b2bb (diff)
gnu: w3m: Enable SSL, disable broken protocols and ciphers.
Fixes <http://bugs.gnu.org/16791>. * gnu/packages/patches/w3m-force-ssl_verify_server-on.patch: New file. * gnu/packages/patches/w3m-disable-sslv2-and-sslv3.patch: New file. * gnu/packages/patches/w3m-disable-weak-ciphers.patch: New file. * gnu/packages/w3m.scm (w3m)[source]: Add patches. * gnu-system.am (dist_patch_DATA): Add the new files.
Diffstat (limited to 'gnu/packages/patches/w3m-force-ssl_verify_server-on.patch')
-rw-r--r--gnu/packages/patches/w3m-force-ssl_verify_server-on.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/patches/w3m-force-ssl_verify_server-on.patch b/gnu/packages/patches/w3m-force-ssl_verify_server-on.patch
new file mode 100644
index 0000000000..dc9f117f9d
--- /dev/null
+++ b/gnu/packages/patches/w3m-force-ssl_verify_server-on.patch
@@ -0,0 +1,24 @@
+Subject: Force ssl_verify_server on.
+
+By default, SSL/TLS certificates are not verified. This enables the
+verification.
+---
+ fm.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/fm.h b/fm.h
+index 8378939..320906c 100644
+--- a/fm.h
++++ b/fm.h
+@@ -1135,7 +1135,7 @@ global int view_unseenobject init(TRUE);
+ #endif
+
+ #if defined(USE_SSL) && defined(USE_SSL_VERIFY)
+-global int ssl_verify_server init(FALSE);
++global int ssl_verify_server init(TRUE);
+ global char *ssl_cert_file init(NULL);
+ global char *ssl_key_file init(NULL);
+ global char *ssl_ca_path init(NULL);
+--
+2.6.4
+