summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-02-11 16:15:00 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-02-19 08:16:47 +0100
commit243eb86c6ffa9d0a5665d90e33f788e2aac8dab5 (patch)
treeba14f0f41459b84f3ce4bef933b865ea42cd9d7b /gnu/packages/patches
parenteb96e148ca50fde3068f365ab4ebb6ab6dbf3dea (diff)
gnu: Add emacs-pasp-mode.
* gnu/packages/patches/emacs-pasp-mode-quote-file-names.patch: New file. * gnu/local.mk: Register it here. * gnu/packages/emacs-xyz.scm (emacs-pasp-mode): New variable.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/emacs-pasp-mode-quote-file-names.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/patches/emacs-pasp-mode-quote-file-names.patch b/gnu/packages/patches/emacs-pasp-mode-quote-file-names.patch
new file mode 100644
index 0000000000..39dc5d0253
--- /dev/null
+++ b/gnu/packages/patches/emacs-pasp-mode-quote-file-names.patch
@@ -0,0 +1,20 @@
+diff --git a/pasp-mode.el b/pasp-mode.el
+index 7f83645..5daf08e 100644
+--- a/pasp-mode.el
++++ b/pasp-mode.el
+@@ -199,9 +199,12 @@
+ Argument ENCODING The current buffer which holds the problem encoding.
+ Optional argument INSTANCE The problem instance which is solved by the encoding.
+ If no instance it is assumed to be also in the encoding file."
+- (if 'instance
+- (concat pasp-clingo-path " " pasp-clingo-options " " encoding " " instance)
+- (concat pasp-clingo-path " " pasp-clingo-options " " encoding)))
++ (if instance
++ (concat pasp-clingo-path " " pasp-clingo-options " "
++ (shell-quote-argument encoding) " "
++ (shell-quote-argument instance))
++ (concat pasp-clingo-path " " pasp-clingo-options " "
++ (shell-quote-argument encoding))))
+
+ (defun pasp-run-clingo (encoding &optional instance)
+ "Run Clingo with some ASP input files.