summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-03-27 10:21:12 -0300
committerVinicius Monego <monego@posteo.net>2024-04-06 08:40:50 -0300
commit2d62d08e45eaf1d60841582963c9143a680adef9 (patch)
tree8587c2ced77d255cf9418314c697de3ee3906440 /gnu/packages/patches
parent1ad77a745fcaaba42f3961225ed141aab2b0b0af (diff)
gnu: opencolorio: Update to 2.3.2.
* gnu/packages/image-processing.scm (opencolorio): Update to 2.3.2. [source]: Remove snippet. [arguments]: Use G-Expressions. <#:configure-flags>: Unset "-DCMAKE-CXX_FLAGS", "-DOCIO_BUILD_STATIC", "-DUSE_EXTERNAL_TINXML", "-DUSE_EXTERNAL_LCMS". Pass "-DCIO_BUILD_GPU_TESTS=false". <#:phases>: Delete the patch-test-suite phase. [native-inputs]: Remove git, pkg-config. Add openimageio, pybind11-2.10, python-wrapper. [inputs]: Remove openexr-2, tinyxml. Add expat, freeglut, glew, imath, libglvnd, minizip-ng, openexr, pystring, yaml-cpp, zlib. [license]: Simplify. * gnu/packages/patches/opencolorio-fix-build-with-gcc11.patch: Delete patch. * gnu/local.mk (dist_patch_DATA): Unregister it. Change-Id: Iafd87762df81d0f5c23089251b4241a57d414dc4
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/opencolorio-fix-build-with-gcc11.patch37
1 files changed, 0 insertions, 37 deletions
diff --git a/gnu/packages/patches/opencolorio-fix-build-with-gcc11.patch b/gnu/packages/patches/opencolorio-fix-build-with-gcc11.patch
deleted file mode 100644
index 06507db206..0000000000
--- a/gnu/packages/patches/opencolorio-fix-build-with-gcc11.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-Fix build failure with GCC 11:
-
-------
-[...]
-/tmp/guix-build-opencolorio-1.1.1.drv-0/source/src/core/ImageDesc.cpp:60:51: error: ‘this’ pointer is null [-Werror=nonnull]
- 60 | os << "width=" << packedImg->getWidth() << ", ";
- | ^
-/tmp/guix-build-opencolorio-1.1.1.drv-0/source/src/core/ImageDesc.cpp:274:10: note: in a call to non-static member function ‘long int OpenColorIO::v1::PackedImageDesc::getWidth() const’
- 274 | long PackedImageDesc::getWidth() const
- | ^~~~~~~~~~~~~~~
-/tmp/guix-build-opencolorio-1.1.1.drv-0/source/src/core/ImageDesc.cpp:61:53: error: ‘this’ pointer is null [-Werror=nonnull]
- 61 | os << "height=" << packedImg->getHeight() << ", ";
- | ^
-/tmp/guix-build-opencolorio-1.1.1.drv-0/source/src/core/ImageDesc.cpp:279:10: note: in a call to non-static member function ‘long int OpenColorIO::v1::PackedImageDesc::getHeight() const’
- 279 | long PackedImageDesc::getHeight() const
- | ^~~~~~~~~~~~~~~
-cc1plus: all warnings being treated as errors
-[...]
-------
-
-Patch copied from Gentoo:
-
-https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=7e726d850502018b6760da78dbd4a419603016b8
-
-diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
-index 1eb691b6..cff9bd83 100644
---- a/src/core/CMakeLists.txt
-+++ b/src/core/CMakeLists.txt
-@@ -23,8 +23,6 @@ if(WIN32)
- if("${CMAKE_BUILD_TYPE}" STREQUAL "Release")
- set(EXTERNAL_COMPILE_FLAGS "${EXTERNAL_COMPILE_FLAGS} /WX")
- endif()
--else()
-- set(EXTERNAL_COMPILE_FLAGS "${EXTERNAL_COMPILE_FLAGS} -Werror")
- endif()
-
- # SHARED