summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-09-22 19:44:10 +0000
committerLudovic Courtès <ludo@gnu.org>2022-10-02 23:22:07 +0200
commit582b1f626f351d0c519c973ba3c49d1c270200bf (patch)
tree4e5d8d5db2e5be9636eed8228f86145f1f20637b /gnu/packages/patches
parentd1c3de6583e24135cdd1a72cf2f5ee758182d402 (diff)
gnu: python-louvain: Fix test.
* gnu/packages/graph.scm (python-louvain)[source]: Add patch. * gnu/packages/patches/python-louvain-fix-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Register patch. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-louvain-fix-test.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-louvain-fix-test.patch b/gnu/packages/patches/python-louvain-fix-test.patch
new file mode 100644
index 0000000000..2127df681c
--- /dev/null
+++ b/gnu/packages/patches/python-louvain-fix-test.patch
@@ -0,0 +1,15 @@
+https://github.com/taynaud/python-louvain/commit/638804ae636dc65306900ef6518ca0a1c9202566.diff
+
+diff --git a/test_community.py b/test_community.py
+index 1ee1976..566a4b1 100644
+--- a/test_community.py
++++ b/test_community.py
+@@ -203,7 +203,7 @@ def test_karate(self):
+ self.assertAlmostEqual(co.modularity(part, graph),
+ co.modularity(part_weight,
+ graph,
+- "test_weight"), places=2)
++ "test_weight"), places=1)
+
+ part_res_low = co.best_partition(graph, resolution=0.1)
+ self.assertTrue(