summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2024-03-20 14:54:26 +0000
committerChristopher Baines <mail@cbaines.net>2024-03-20 14:54:26 +0000
commit8fa07612644339a2bf21be9ee924e6ff1e0ec81d (patch)
treedbcb73053fac420077d45b20d9460134818ad2be /gnu/packages/patches
parentebe30c375495e7232551b32b6771f3c06a676f41 (diff)
parent69951a61a1d8f1f2135ea2dc836738be282b97bc (diff)
Merge remote-tracking branch 'savannah/master' into gnome-team
Change-Id: Iec8e15b79c6fde516294c2bfcaf8ee3575b1f745
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/qemu-build-info-manual.patch37
-rw-r--r--gnu/packages/patches/qemu-disable-bios-tables-test.patch (renamed from gnu/packages/patches/qemu-disable-some-qtests-tests.patch)36
2 files changed, 22 insertions, 51 deletions
diff --git a/gnu/packages/patches/qemu-build-info-manual.patch b/gnu/packages/patches/qemu-build-info-manual.patch
index ff28266aaa..0950787810 100644
--- a/gnu/packages/patches/qemu-build-info-manual.patch
+++ b/gnu/packages/patches/qemu-build-info-manual.patch
@@ -13,50 +13,33 @@ readers.
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
diff --git a/docs/meson.build b/docs/meson.build
+index 9040f860ae..2ae7886fcb 100644
--- a/docs/meson.build
+++ b/docs/meson.build
-@@ -92,4 +92,25 @@ if build_docs
+@@ -98,4 +98,26 @@ if build_docs
alias_target('sphinxdocs', sphinxdocs)
alias_target('html', sphinxdocs)
alias_target('man', sphinxmans)
+
-+ # Generate a Texinfo version of the QEMU manual.
++ # Add a target to build and install a Texinfo version of the QEMU
++ # manual, if 'makeinfo' is available.
+ makeinfo = find_program(['texi2any', 'makeinfo'])
+ if makeinfo.found()
+ sphinxtexi = custom_target(
-+ 'QEMU manual generated texinfo source',
-+ output: ['QEMU.texi', 'sphinxtexi.stamp'],
++ 'qemu.texi',
++ output: ['qemu.texi', 'sphinxtexi.stamp'],
+ depfile: 'sphinxtexi.d',
+ command: [SPHINX_ARGS, '-Ddepfile=@DEPFILE@',
+ '-Ddepfile_stamp=@OUTPUT1@', '-b', 'texinfo',
-+ meson.current_source_dir(), meson.current_build_dir()])
++ '-d', private_dir, input_dir, meson.current_build_dir()])
+ sphinxinfo = custom_target(
-+ 'QEMU info manual',
++ 'qemu.info',
+ input: sphinxtexi,
-+ output: 'QEMU.info',
++ output: 'qemu.info',
+ install: true,
+ install_dir: get_option('infodir'),
-+ command: [makeinfo, '--no-split', '@INPUT0@', '--output=@OUTPUT@'])
++ command: [makeinfo, '--no-split', '--output=@OUTPUT@', '@INPUT0@'])
+ alias_target('texi', sphinxtexi)
+ alias_target('info', sphinxinfo)
+ endif
endif
-diff --git a/meson.build b/meson.build
---- a/meson.build
-+++ b/meson.build
-@@ -37,6 +37,7 @@ endif
- qemu_confdir = get_option('sysconfdir') / get_option('qemu_suffix')
- qemu_datadir = get_option('datadir') / get_option('qemu_suffix')
- qemu_docdir = get_option('docdir') / get_option('qemu_suffix')
-+qemu_infodir = get_option('infodir') / get_option('qemu_suffix')
- qemu_moddir = get_option('libdir') / get_option('qemu_suffix')
-
- qemu_desktopdir = get_option('datadir') / 'applications'
-@@ -3698,6 +3699,7 @@ else
- summary_info += {'local state directory': 'queried at runtime'}
- endif
- summary_info += {'Doc directory': get_option('prefix') / get_option('docdir')}
-+summary_info += {'Info directory': get_option('prefix') / get_option('infodir')}
- summary_info += {'Build directory': meson.current_build_dir()}
- summary_info += {'Source path': meson.current_source_dir()}
- summary_info += {'GIT submodules': config_host['GIT_SUBMODULES']}
diff --git a/gnu/packages/patches/qemu-disable-some-qtests-tests.patch b/gnu/packages/patches/qemu-disable-bios-tables-test.patch
index f60698de8f..39b7b0b53c 100644
--- a/gnu/packages/patches/qemu-disable-some-qtests-tests.patch
+++ b/gnu/packages/patches/qemu-disable-bios-tables-test.patch
@@ -1,20 +1,18 @@
-Disable the qtest-aarch64/migration-test, which sometimes fail
-non-deterministically (see:
-https://gitlab.com/qemu-project/qemu/-/issues/1230).
+The bios-tables-test may fail; disable it (see: https://gitlab.com/qemu-project/qemu/-/issues/1098)
-Also disable the bios-tables-test, which may fail on older machines (see:
-https://gitlab.com/qemu-project/qemu/-/issues/1098).
-
---- qemu-8.1.0/tests/qtest/meson.build.old 2023-08-30 11:48:27.871146249 -0400
-+++ qemu-8.1.0/tests/qtest/meson.build 2023-08-30 13:53:25.994084948 -0400
-@@ -1,6 +1,5 @@
+diff --git a/tests/qtest/meson.build b/tests/qtest/meson.build
+index f096cf3ecd..82f6e1ffeb 100644
+--- a/tests/qtest/meson.build
++++ b/tests/qtest/meson.build
+@@ -1,7 +1,6 @@
slow_qtests = {
'ahci-test' : 60,
+ 'aspeed_smc-test': 360,
- 'bios-tables-test' : 120,
'boot-serial-test' : 60,
'migration-test' : 150,
'npcm7xx_pwm-test': 150,
-@@ -81,9 +80,6 @@
+@@ -82,9 +81,6 @@ qtests_i386 = \
config_all_devices.has_key('CONFIG_Q35') and \
config_all_devices.has_key('CONFIG_VIRTIO_PCI') and \
slirp.found() ? ['virtio-net-failover'] : []) + \
@@ -24,27 +22,17 @@ https://gitlab.com/qemu-project/qemu/-/issues/1098).
qtests_pci + \
qtests_cxl + \
['fdc-test',
-@@ -212,7 +208,6 @@
-
+@@ -213,7 +209,6 @@ qtests_arm = \
+
# TODO: once aarch64 TCG is fixed on ARM 32 bit host, make bios-tables-test unconditional
qtests_aarch64 = \
- (cpu != 'arm' and unpack_edk2_blobs ? ['bios-tables-test'] : []) + \
(config_all.has_key('CONFIG_TCG') and config_all_devices.has_key('CONFIG_TPM_TIS_SYSBUS') ? \
['tpm-tis-device-test', 'tpm-tis-device-swtpm-test'] : []) + \
(config_all_devices.has_key('CONFIG_XLNX_ZYNQMP_ARM') ? ['xlnx-can-test', 'fuzz-xlnx-dp-test'] : []) + \
-@@ -222,8 +217,7 @@
- config_all_devices.has_key('CONFIG_TPM_TIS_I2C') ? ['tpm-tis-i2c-test'] : []) + \
- ['arm-cpu-features',
- 'numa-test',
-- 'boot-serial-test',
-- 'migration-test']
-+ 'boot-serial-test']
-
- qtests_s390x = \
- qtests_filter + \
-@@ -301,7 +295,6 @@
+@@ -304,7 +299,6 @@ if gnutls.found()
endif
-
+
qtests = {
- 'bios-tables-test': [io, 'boot-sector.c', 'acpi-utils.c', 'tpm-emu.c'],
'cdrom-test': files('boot-sector.c'),